Bug 647645 - RFE: JBoss AS Start op - make the err mgs clearer: "The 'javaHome' connection property must be set in order to start the application server or to stop it via script."
RFE: JBoss AS Start op - make the err mgs clearer: "The 'javaHome' connection...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
1.4
Unspecified Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-28 22:05 EDT by Ondřej Žižka
Modified: 2014-06-27 17:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-27 17:29:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ondřej Žižka 2010-10-28 22:05:53 EDT
ENV:
 JON 2.4.0
 IBM JDK 1.6
 RHEL 6
 EAP 5.1.0.GA

STR:
1) Inventorize the EAP instance
2) Restart it -> Failure after some time
3) Check the failure reason, which is:


java.lang.IllegalStateException: The 'javaHome' connection property must be set in order to start the application server or to stop it via script.
	at org.rhq.plugins.jbossas5.ApplicationServerOperationsDelegate.initProcessExecution(ApplicationServerOperationsDelegate.java:273)
	at org.rhq.plugins.jbossas5.ApplicationServerOperationsDelegate.start(ApplicationServerOperationsDelegate.java:217)
	at org.rhq.plugins.jbossas5.ApplicationServerOperationsDelegate.invoke(ApplicationServerOperationsDelegate.java:129)
	at org.rhq.plugins.jbossas5.ApplicationServerComponent.invokeOperation(ApplicationServerComponent.java:461)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:525)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:636)
Comment 1 Ondřej Žižka 2010-10-28 22:12:59 EDT
It's OpenJDK 1.6, not IBM JDK.
Comment 2 Ian Springer 2010-10-29 00:25:12 EDT
Did you try setting the javaHome connection property as the error message suggests?

Was the JAVA_HOME environment variable set in the EAP process?
Comment 3 Ondřej Žižka 2010-10-29 10:45:41 EDT
1) No, about to try that. At first sight I did not realize that it's referring to the Connection sub-tab.

2) No, JAVA_HOME was empty in all env - EAP, agent, server.
   JAVA_HOME from EAP's env is taken automatically for this to be used?
Comment 4 Ian Springer 2010-10-29 11:22:32 EDT
1) That should do the trick.

2) Yes, that's how the discovery code sets the default for the javaHome conn prop. If the env var isn't set, the prop defaults to null, which is probably what happened in your case.
Comment 5 Ondřej Žižka 2010-10-29 11:35:05 EDT
1) Worked.

2) Also worked.

Maybe the error message should me more clear about where to set the java home, or even better, contain a link to the Connection subtab - perhaps in the new GWT UI. 

And it could also mention setting EAP's JAVA_HOME.

I'm renaming this to "RFE: JBoss AS Start op - make the err mgs clearer: ..."

Note You need to log in before you can comment on or make changes to this bug.