Bug 64770 - printconf-gui does not allow printing to smb or lpd remote print servers
printconf-gui does not allow printing to smb or lpd remote print servers
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 14:33 EDT by Mel Herndon
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-02 17:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mel Herndon 2002-05-10 14:33:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
When following printconf documentation regarding proper installation of a LPD or Samba printer share on a remote print server attempts to print test page immediately error with "There was an error trying to print"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install either lpd or smb remote printer
2.Attempt to print using the test print option in printconf-gui
3.
 

Actual Results:  An error immediately occurs stating that an error has occured.

Expected Results:  At least see a pause while it attempts to spool and connect to remote printer

Additional info:

The LPD was trying to connect to a Mandrake 8.2 machine with a Canon BJC2100 connected on lp0, runinng CUPS. Verification of printer queue name, ip, ping, traceroute, etc.indicated there is connectivity to machine. After days on google groups, in IRC etc. All attempts to connect to this machine failed.

The Samba share was attempting to print to a Windows ME machine. Same exact error message. Checked to make sure everything is installed. I can open konqueror and type smb://<ip address/hostname> and it connects to the shared folder resources quickly.

Printer configuration with Linux in general should not require days of troubleshooting to be able to setup a printer. Please note that running Suse Linux 7.3 and or Mandrake 8.2 client with their ability to check the network for shared resources saves everyone time and effort. Even if I setup the printer through Yast2 or Control Center for Mandrake manually, I still was able to print to the shared printer. 

Note as well that following CUPS documentation and using the funky web based interface with 7.2 did successfully find the LPD printer. The problem again was that it would see the printer, change the status from idle to processing and never print a thing. Email me should you want the printcap file or any other files you feel in question.
Comment 1 Rick Runowski 2002-05-13 23:15:59 EDT
I am also having this problem now that I have upgraded to 7.3.  Some additional
information.  If I use the command 

smbclient \\\\host\\printer -P 

and then issue 'print test.txt'  The windows printer will print, however, I
cannot get anything to print otherwise.  The printer worked fine in RH 7.2
suggesting the windows box and smb settings are correct.  I can connect to all
other shares normally.  Please let me know if I can provide any more information.

--Rick
Comment 2 Tim Waugh 2002-05-27 12:02:44 EDT
Please attach /etc/alchemist/namespace/printconf/local.adl.  Thanks.
Comment 3 Bas Mevissen 2002-09-02 17:27:05 EDT
I had problems too. The SMB printing problem was solved by entering 
\\surf\hp5l in the "share" box. I misinterpreted the ip address box as the 
place to enter the host name. So I can SMB print now. Maybe this helps the 
bug reporters too.
Comment 4 Tim Waugh 2002-09-03 09:23:56 EDT
This is what the documentation says to do though, and the original bug 
reporter says "When following [...] documentation". 
 
lernlinux@houston.rr.com: If this isn't it, please re-open this bug report and 
attach the file I need.

Note You need to log in before you can comment on or make changes to this bug.