Bug 64773 - adsl-setup doesn't properly generate configuration file
Summary: adsl-setup doesn't properly generate configuration file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rp-pppoe   
(Show other bugs)
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-10 19:11 UTC by Need Real Name
Modified: 2007-04-18 16:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-08 23:10:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-05-10 19:11:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
- adsl-setup doesn't generate configuration file
/etc/.../network-scripts/ifcfg-ppp. (or /etc/ppp/pppoe.conf)
- The ADSL connection won't come up on boot even if adsl-setup was told to do so.
- I can connect by executing .../network-scripts/ifup-ppp, but basename
complains about no argument when executing the script.
- /sbin/ifup ppp can't be used (missing ifcfg-ppp)
- .../network-scripts/ifdown-ppp doesn't work


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use adsl-setup.
2.
3.
	

Additional info:

Comment 1 Need Real Name 2002-05-14 16:17:51 UTC
I've been able to solve the problem by doing the following:
   - Renaming ifcfg- to ifcfg-ppp0 and changing DEVICE= to DEVICE=ppp0 
   - Renaming ifup-ppp to ifup-ppp0
   - Renaming ifdown-ppp to ifdown-ppp0

Now both /sbin/ifup ppp0  and /sbin/ifdown ppp0 work.

Comment 2 Need Real Name 2002-05-15 09:14:37 UTC
Sorry, the only neccessary thing is to rename ifcfg- to ifcfg-ppp0 and change
DEVICE= to DEVICE=ppp0. So it seems that some variable in the adsl-setup is
being set to "" instead of "ppp0".


Comment 3 Eric LAGALISSE 2002-05-21 22:04:48 UTC
It seem that the Rawhide version of rp-pppoe fix this problem... rp-pppoe.3.3.5
Personnaly i use the original version from roaming penguin website and it works

Comment 4 Eric LAGALISSE 2002-05-21 22:15:23 UTC
Sorry i've made a mistake, it should be corrected as mentionned in bugzilla 
59236 but it is not.

Comment 5 J.M.Roth 2002-06-08 23:10:40 UTC
Uh yeah, this is annoying. In 7.2 this worked quite well. Too stupid when you 
get stuck at this point.
There's this strange dsl_device variable which is never defined if the 
previous 'if' isn't true... In fact I don't really know what's wrong but the 
script *is* buggy.


Comment 6 Ngo Than 2002-06-09 17:13:31 UTC
it's fixed in 3.4-4. You will find it in next rawhide release

Comment 7 Michael Schwendt 2002-07-31 20:12:53 UTC
This is an FAQ in Linux message boards. Dial-up servers without X Windows are a
common thing and people are failing to set up ifcfg-ppp0 due to this bug. I
wonder why Red Hat has not released an errata package for this?



Note You need to log in before you can comment on or make changes to this bug.