Bug 64779 - multi-tasking is not working smoothly with sound
multi-tasking is not working smoothly with sound
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 16:23 EDT by Barry Trout
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-22 10:52:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry Trout 2002-05-10 16:23:54 EDT
Description of Problem:

When I do task such as read a cdrom with listening to thelinuxshow.com via the
web ... the sound is chopped to threads.  It seems to be the mult-tasking of the
new kernel ... 

Version-Release number of selected component (if applicable):
7.3

How Reproducible:
everytime

Steps to Reproduce:
1. Install 7.3 out of the box
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Nathan G. Grennan 2002-05-13 03:59:27 EDT
This is likely do to the new default of disabling dma on cdrom drives. This
causes cdrom access to cause insane latency. You can probably found the bug
report I made about this problem if you look into bugzilla. It was marked
NOTABUG. I recommend commenting out the offending lines in /etc/rc.d/rc.sysinit.
Redhat recommends you set dma to 1 using sysctl.
Comment 2 Arjan van de Ven 2002-05-22 10:52:53 EDT
it's easy to check this temporary by typing
hdparm -d 1 /dev/hdc
(assuming hdc is your cdrom)

Does that fix it ?

Note You need to log in before you can comment on or make changes to this bug.