Bug 647804 - [abrt] ibus-anthy-1.2.3-2.fc13: segment.py:67:to_katakana:UnicodeDecodeError: 'utf8' codec can't decode byte 0xe3 in position 0: unexpected end of data
[abrt] ibus-anthy-1.2.3-2.fc13: segment.py:67:to_katakana:UnicodeDecodeError:...
Status: CLOSED DUPLICATE of bug 644771
Product: Fedora
Classification: Fedora
Component: ibus-anthy (Show other bugs)
13
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:487193fc
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-29 10:16 EDT by Takehiko Abe
Modified: 2010-10-29 10:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-29 10:35:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (1020 bytes, text/plain)
2010-10-29 10:17 EDT, Takehiko Abe
no flags Details

  None (edit)
Description Takehiko Abe 2010-10-29 10:16:57 EDT
abrt version: 1.1.13
architecture: x86_64
cmdline: python /usr/share/ibus-anthy/engine/main.py --ibus
component: ibus-anthy
executable: /usr/share/ibus-anthy/engine/main.py
kernel: 2.6.36+
package: ibus-anthy-1.2.3-2.fc13
reason: segment.py:67:to_katakana:UnicodeDecodeError: 'utf8' codec can't decode byte 0xe3 in position 0: unexpected end of data
release: Fedora release 13 (Goddard)
time: 1288361383
uid: 1000

backtrace
-----
segment.py:67:to_katakana:UnicodeDecodeError: 'utf8' codec can't decode byte 0xe3 in position 0: unexpected end of data

Traceback (most recent call last):
  File "/usr/share/ibus-anthy/engine/engine.py", line 990, in __update
    self.__update_convert_chars()
  File "/usr/share/ibus-anthy/engine/engine.py", line 920, in __update_convert_chars
    text, cursor = self.__preedit_ja_string.get_katakana(True)
  File "/usr/share/ibus-anthy/engine/jastring.py", line 232, in get_katakana
    text_before = R(u"".join(map(conv, self.__segments[:self.__cursor])))
  File "/usr/share/ibus-anthy/engine/jastring.py", line 230, in <lambda>
    conv = lambda s: s.to_katakana()
  File "/usr/share/ibus-anthy/engine/segment.py", line 67, in to_katakana
    return u"".join(map(lambda c: hiragana_katakana_table.get(c, (c, c, c))[0], self._jachars))
UnicodeDecodeError: 'utf8' codec can't decode byte 0xe3 in position 0: unexpected end of data

Local variables in innermost frame:
self: <romaji.RomajiSegment object at 0x1479390>

How to reproduce
-----
1. Type some hiragana chars (with romaji method)
2. Try to convert them into katakana with shortcut (control+K in my case)

--> crash

Reproduceable consistently.
Comment 1 Takehiko Abe 2010-10-29 10:17:00 EDT
Created attachment 456479 [details]
File: backtrace
Comment 2 Takehiko Abe 2010-10-29 10:35:39 EDT
Doh! Found: 

  https://bugzilla.redhat.com/show_bug.cgi?id=644771#c10

| Fedora Update System 2010-10-26 21:42:44 EDT
|
| ibus-anthy-1.2.4-2.fc14 has been submitted as an update for Fedora 14.

How come I got update to 1.2.3-2 on 2010-10-28?
Anyways it fixed the problem.

Sorry.

*** This bug has been marked as a duplicate of bug 644771 ***

Note You need to log in before you can comment on or make changes to this bug.