Bug 647815 - Currently you can only revert back one bundle version, should be able to revert back several
Currently you can only revert back one bundle version, should be able to reve...
Status: CLOSED DUPLICATE of bug 645412
Product: RHQ Project
Classification: Other
Component: Provisioning (Show other bugs)
3.0.0
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-29 11:11 EDT by dsteigne
Modified: 2011-03-24 10:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-24 10:10:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dsteigne 2010-10-29 11:11:59 EDT
Description of problem:
Unable to revert to more than one(previous) versions of the bundle.

Version-Release number of selected component (if applicable):
2.4

Steps to Reproduce:
1. install JON server
2. install JBEAP instances x 2 in windows 2003 server x86
3. install JON agent
4. create a compatible windows group - group1
5. create a bundle - JBossApps - version 1.0
6. deploy bundle v1.0 to group1
7. create a bundle JBossApps - version 1.1
8. Deploy bundle v1.1 to group1
9. Create bundle JBosApps - version 1.2
10. Deploy bundle v1.2 to group1
11. Revert bundle previous version i.e v1.1
12. try reverting it again i.e to v1.0

You get an error saying there is no prior deployments before this. 

 
Actual results:


Expected results:


Additional info:
Comment 1 John Mazzitelli 2010-12-13 13:48:36 EST
this is probably gonna be hard to implement. recommend we skip this in the short term.
Comment 2 John Mazzitelli 2011-03-24 10:10:14 EDT
You should be able to revert back, one at a time, to the original, initial bundle install. If you want to revert that original (that is, uninstall the bundle entirely), we have the ability to purge a bundle now. which is what I think this issue is asking for.

we can close this since the purge will be verified via a previous BZ issue - bug #645412.

*** This bug has been marked as a duplicate of bug 645412 ***

Note You need to log in before you can comment on or make changes to this bug.