Bug 64782 - X freezes after restore from suspend-to-disk (ATI Radeon M6)
X freezes after restore from suspend-to-disk (ATI Radeon M6)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 82776
  Show dependency treegraph
 
Reported: 2002-05-10 17:02 EDT by Matthew Saltzman
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 17:17:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2002-05-10 17:02:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Using the suspend-to-disk utility on Dell Latitude C610.  On restore from S2D,
VCs seem to work fine, however if suspend is done from X display or on switching
to X display after restore, the display freezes, no cursor, no keyboard.  The
machine must be power-cycled to regain control.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Dell S2D utility and create S2D partition.
2.Boot Linux
3.Invoke S2D (<Fn>-A key combo)
4.Power machine back on.
	

Actual Results:  X display freezes as described above.

Expected Results:  Fully functional X display.

Additional info:

When going into suspend mode, the X display becomes scrambled.  On restore, the
display looks correct, but does not respond to mouse or keyboard.

Other model Dell Latitudes with other X drivers do not exhibit the problem.
Comment 1 Mike A. Harris 2002-05-13 02:44:56 EDT
Is your machine running the latest BIOS update from Dell?
Comment 2 Matthew Saltzman 2002-05-13 07:36:23 EDT
Yes, A07 released 4/12/2002.
Comment 3 Mike A. Harris 2002-05-28 06:05:17 EDT
X11 does not cope well with clock skew during suspend/resume cycles.  It
also does not cope well with clock changes at all during runtime.

Are you running any clock sync tools?
Comment 4 Matthew Saltzman 2002-05-28 20:50:22 EDT
Yes, adjtimex.  Keeps pretty fair time too.  I did just try again, and the times
before and after suspend followed by immediate resume look about right.  Same
symptoms.

Note that there is a cursor and it moves when you make motions on the touchpad,
but clicks don't have any effect and you can't mouse past the edge of the screen
and get it to flip (even though the option is set and works normally).
Comment 5 Derek Viljoen 2002-10-08 11:35:15 EDT
I'm having mouse problems on a Latitude CPxJ, but it's not related to
suspend/resume.  Sometimes I log out and my mouse just stops working altogether.
 I Ctrl-Alt-Backspace at the GDM login, and it still doesn't come back.  I need
to reboot.  I'm also using the latest BIOS updates for my model.

This sounds like a Dell BIOS issue though, because the problems are too similar.
Comment 6 Mike A. Harris 2002-12-19 05:10:38 EST
I believe this is a duplicate issue of 63509 and fixed by the same.

*** This bug has been marked as a duplicate of 63509 ***
Comment 7 Mike A. Harris 2002-12-21 17:54:17 EST
Reopening as you've indicated this problem isn't resolved by the one
I duped it against.
Comment 8 Mike A. Harris 2002-12-21 17:54:56 EST
mjs: Are you using 7.3 still or 8.0 now?
Comment 9 Matthew Saltzman 2002-12-21 22:28:33 EST
Currently using 8.0, kernel-2.4.18-18.8.0, all other updates, XFree86-4.2.1-10.

(BTW, 8.0 did fix the screensaver crashes for me, and either 8.0 or acroread
5.06 fixed the incorrectly-aligned full-screeen acroread mode.  Don't recall
those bug numbers offhand, though.)
Comment 10 Mike A. Harris 2003-01-15 13:18:44 EST
Have you tried Red Hat Linux 8.0 by chance?  If so, is the problem present
still?

I've got test packages for 8,0 avail that I believe might fix this if 8.0
doesn't already.

XFree86-4.2.1-10.5 on ftp://people.redhat.com/mharris/testing/8.0

Can you test this perhaps?
Comment 11 Matthew Saltzman 2003-01-15 14:17:28 EST
Yes, currently running 8.0 with all updates.  Unfortunately, no joy with
XFree86-4.2.1-10.5.  Below, I've reproduced my comments from bug #63509 which
led you to reopen this one.  The same symptoms occur with XFree86-4.2.1-10.5.

-------------- From Bug #63509 ---------------
My test result notes:

(1) This appears to fix the loss of key repeat when the clock goes back (can't
recall which bug that is).

(2) Re: Bug 64782.  The behavior has changed but is not fixed.  On resume from
APM suspend-to-disk, the X screen is completely frozen and does not respond to
mouse or keyboard (where I used to be able to move the mouse cursor but not
click or keyboard).  There is intermittent disk activity (where I don't recall
having any before).  I can ssh to  the machine and see that X has run away and
is taking almost 100% of CPU.
----------------------------------------------
Comment 12 Matthew Saltzman 2003-01-15 15:47:37 EST
One more data point: Setting CHANGEVT="7" in /etc/sysconfig/apmd has no effect,
ie.e, the symptoms appear either way.
Comment 13 Kjartan Maraas 2003-02-10 10:00:13 EST
Maybe this could be of help:

http://cpbotha.net/dri_resume.html
Comment 14 Matthew Saltzman 2003-04-27 21:52:37 EDT
With XFree86-4.3.0-5, restore comes back with the display blank and no screen
image, cursor, or keyboard.  I can still log in remotely, and X is using 99% of CPU.

(Interestingly, with the XFree86 distributed with RH9, I noticed the following:
 If I suspended to disk from the X login screen (using GNOME), then resume
seemed to work.  I could enter userid and password.  When I logged in from that
screen, then the screen froze as before.  Using the test XFree86, the freeze
occurs with the login screen also.)

BTW, I am now using a Dell Latitude C640 (Radeon 7500 Mobility) BIOS A08, Red
Hat Linux 9 with all updates plus the test version of XFree86.
Comment 15 Mike A. Harris 2004-08-19 17:17:43 EDT
Please try upgrading to our latest OS release "Fedora Core 2" and
see if this problem persists.  If the issue does persist, please
file a new bug report in X.Org bugzilla located at:

    http://bugs.freedesktop.org

Setting status to "CURRENTRELEASE" for now.  Feel free to reopen
with URL to upstream bug report if issue still occurs.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.