Bug 647852 - [abrt] imsettings-0.108.1-2.fc15: pthread_mutex_lock: Process /usr/libexec/im-settings-daemon was killed by signal 11 (SIGSEGV)
[abrt] imsettings-0.108.1-2.fc15: pthread_mutex_lock: Process /usr/libexec/im...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
x86_64 Unspecified
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
abrt_hash:3a860817d163fe16571b47d661e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-29 13:30 EDT by Clyde E. Kunkel
Modified: 2011-01-05 06:23 EST (History)
2 users (show)

See Also:
Fixed In Version: imsettings-1.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-05 06:23:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (16.88 KB, text/plain)
2010-10-29 13:30 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2010-10-29 13:30:48 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/im-settings-daemon
component: imsettings
crash_function: pthread_mutex_lock
executable: /usr/libexec/im-settings-daemon
kernel: 2.6.36-1.fc15.x86_64
package: imsettings-0.108.1-2.fc15
rating: 3
reason: Process /usr/libexec/im-settings-daemon was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1288373074
uid: 500

How to reproduce
-----
1. booted into gnome desktop
2. looked at some mail in thunderbird
3.
Comment 1 Clyde E. Kunkel 2010-10-29 13:30:49 EDT
Created attachment 456523 [details]
File: backtrace
Comment 2 Akira TAGOH 2010-11-07 22:15:15 EST
Didn't you see this issue when you are going to log out from your desktop, no?
Comment 3 Clyde E. Kunkel 2010-11-08 09:31:58 EST
I don't think so, but then it is possible and abrt reported at the next login.  Also, I haven't seen it repeated since the original report.  I would say lets wait a few cycles to see if it is repeated and if not, then I will close it.  Also, there are some other gnome tasks that are aborting during initial login and they may be inadvertently contributing.

Thanks for looking at this.
Comment 4 Clyde E. Kunkel 2010-11-08 09:59:08 EST
OK, now I see that imsettings.x86_64 0:0.108.1-4.fc15 is available but --skip-broken keeps it from being installed due to broken dependencies.  Lets assume that this bz will be satisfied when the update is installed.  It looks like the main dependency culprit is libnotify.
Comment 5 Akira TAGOH 2010-11-09 23:39:58 EST
Hm, I don't think that makes any difference for this issue though. but that would be nice if there are more info to reproduce this. let me just set a flag for your next report.
Comment 6 Akira TAGOH 2011-01-05 06:23:51 EST
The problematic code causing this issue isn't in imsettings-1.0.0-1.fc15 anymore. so closing.

Note You need to log in before you can comment on or make changes to this bug.