Bug 64786 - Evolution crashes when trying to use SSL/TLS
Evolution crashes when trying to use SSL/TLS
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 17:45 EDT by Nathan G. Grennan
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 00:56:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-05-10 17:45:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020501

Description of problem:
I in the last few days upgraded both my desktop and a server I administrate on
the internet to Redhat 7.3. Last night I converted the server from Sendmail to
Postfix. In the process I decided to play with SSL/TLS. So I followed
instructions of creating the keys and got them installed. Then I configured
Evolution to use SSL for Sending mail. Then I tried sending a very simple test
message to myself through the server. The first time I got a prompt to accept
the SSL certificate of the server, which I did. Then the "mail" part of
Evolution crashed once it tried to actually send the message. I have tried it
multiple times and get the exact same result each time. The "mail" part crashes
and leaves the main window.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start Evolution
2. Go to the Tools menu and Mail Settings
3. Select Edit the default account
4. Go to the Sending Mail tab
5. Select SSL
6. Click OK
7. Click OK
8. Click New message, set To:, set Subject, set Body.
9. Click Send
	

Actual Results:  Part of Evolution crashs with the message:

The Evolution component that handles folders of type "mail" has unexpectedly
quit. You will need to quit Evolution and restart to access that data again.

Expected Results:  The message to go through the mail server normally or an
error message of what I am doing wrong.

Additional info:

Eariler I was using Evolution 1.0.3-4 and have since upgraded to 1.0.3-6. The
upgrade had no effect on the bug. It did seem to disable the recovery of
messages after restarting Evolution. With 1.0.3-4 if I clicked New Message after
restarting Evolution after a crash I would get a dialog saying Evolution had
found messages to recover. When using 1.0.3-6 I don't see this.

I also wonder why you haven't upgraded to 1.0.4? From what I have read it
changes the SSL/TLS code to allow Always, When Avaiable, and Never like Mozilla.
I suggest the changes to Evolution in 1.0.4 in the area of SSL/TLS may have
fixed this directly bug, or the code was rewritten enough that it is no longer
an issue.
Comment 1 Jeremy Katz 2002-05-10 18:46:31 EDT
Actually, the major changes to the SSL handling are only on the HEAD branch of
evolution development and not the 1.0.x stable series.  An upgrade was not done
to avoid the potential impact of changes (two easily auditable patches were
added and that's it).  

ISTR talk of this problem upstream, but I'll have to trawl through my archives
to check for what came about after the discussions
Comment 2 Nathan G. Grennan 2002-05-13 00:56:09 EDT
I just tried using Ximian's rpm package for Evolution 1.0.5. I had to rpm -i
--nodeps  install it because it wanted slightly newer versions of certain
libraries than I could find for redhat both in RedHat 7.3 or in Gnomehide for
Skipjack. It does seem to run fine though and does fix the bug with the mail
compentent crashing when trying to send out using TLS. As you mentioned it
doesn't seem to have the newer SSL features.
Comment 3 Nathan G. Grennan 2002-05-23 00:26:03 EDT
Evolution 1.0.5 in Gnomehide for RedHat 7.3 fixes the bug.

Note You need to log in before you can comment on or make changes to this bug.