Bug 64792 - gnome-panel does not swallow applications
gnome-panel does not swallow applications
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-10 18:59 EDT by Alessandro Tommasi
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-19 11:08:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alessandro Tommasi 2002-05-10 18:59:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Adding a swallowed application to a gnome-panel results in the panel showing an
empty applet, and the application running in a separate window instead of inside
the panel

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.right click on a gnome-panel, panel, add to panel, swallowed app...
2.fill the form with your fav app, e.g. "xload" as both command and title of the
window to swallow.
3.click OK
	

Actual Results:  panel shows empty applet, application runs in a separate window.

Expected Results:  application running in the appropriate space inside the panel.

Additional info:

Setup is very standard: fresh 7.3 installation, desktop is (obviously) gnome,
window manager is sawfish. Using xwininfo on the app, window shows that the
title is just as expected by the gnome panel for the swallowing.
Comment 1 Havoc Pennington 2002-07-06 19:03:09 EDT
This feature has been removed from rawhide, because it can't really be
implemented reliably.

Note You need to log in before you can comment on or make changes to this bug.