Bug 647930 - disabling plugin causes agent to send lots of additional availability reports
disabling plugin causes agent to send lots of additional availability reports
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
3.0.0
Unspecified Unspecified
low Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks: jon30-bugs 648992
  Show dependency treegraph
 
Reported: 2010-10-29 17:04 EDT by John Mazzitelli
Modified: 2011-05-23 21:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 648992 651886 (view as bug list)
Environment:
Last Closed: 2011-05-23 21:11:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2010-10-29 17:04:27 EDT
After disabling a plugin, the agent can begin to sends lots of availability reports to the server, more than expected. This happens if you have resources already in inventory (whether committed or not - i.e. in COMMITTED or NEW inventory status).

The problem is in :

org.rhq.core.pc.inventory.InventoryManager.mergeUnknownResources(Set<Integer>)

We weren't removing the IDs from the set being passed in by the caller, thus we never removed the resources that were disabled from the set.

Workaround: re-enable all plugins for which you have resources in inventory OR uninventory all resources that are in inventory that are of types found in plugins that are to be disabled. If the resources are in NEW status, you must commit them first, in order to be able to uninventory them. Its best to do this while the agents are down.
Comment 1 John Mazzitelli 2010-10-29 17:08:19 EDT
this is fixed - master commit: 7155896be74b82b2a9be7b1358103a4e2182fbcf

To test:

1) Start a RHQ Server and RHQ Agent
2) Commit the RHQ Server to inventory
3) Shutdown the agent
3) Go to Administration>Plugins and disable the rhq-server plugin
4) Restart the agent

Watch the server logs for about 10 minutes. After the initial sync between server and agent, you should not see availability reports getting sent up to the server every minute. The default avail scan is 5 minutes so when the agent reaches steady state, it should only send avail reports every 5 minutes. If you see avail reports come into the server every 30s or 60s after the agent has been running 5 or 10 minutes, this bug is still not fixed.
Comment 2 John Mazzitelli 2010-11-10 09:50:14 EST
cherry-picked over to release-3.0.0 branch: cd5a890ea772fc50d3a0516be63e789070dabf42
Comment 3 Corey Welton 2011-01-03 23:36:42 EST
QA Verified, after following steps above, I am not seeing reams of avail reports being generated in the server log.
Comment 4 Corey Welton 2011-05-23 21:11:21 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:11:21 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.