Bug 64795 - Bad: useradd does not add a user name that starts with a number.
Summary: Bad: useradd does not add a user name that starts with a number.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: David Lawrence
URL: useradd: invalid user name `255test'
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-10 23:55 UTC by Fred Wood
Modified: 2007-04-18 16:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 19:11:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fred Wood 2002-05-10 23:55:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
When adding a user name that starts with a number i.e. 255test useradd will not 
add the user saying that it is an invalid user name.  I can add a user name 
that starts with a number through the start here user maintenance graphics mode.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use the useradd command line as follows:
2./usr/sbin/useradd -d /home/255test -g users -s /bin/bash -m 255test
3.It works like this every time.
	

Actual Results:  No user was added.

Expected Results:  The user should have been added.

Additional info:

Comment 1 Petri T. Koistinen 2002-11-21 20:06:40 UTC
We have same problem with Red Hat 7.3. Well, is good policy, but how can I
disable it?

Comment 2 Eido Inoue 2004-09-23 19:11:20 UTC
you can't disable it. this is by design. the first character must be
alphanumeric, although in the next release you may mix case.


Note You need to log in before you can comment on or make changes to this bug.