Bug 647965 - proftpd-1.3.3c is available
Summary: proftpd-1.3.3c is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: proftpd
Version: rawhide
Hardware: Unspecified
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-30 03:36 UTC by Philip Prindeville
Modified: 2010-11-19 18:33 UTC (History)
3 users (show)

Fixed In Version: proftpd-1.3.3c-1.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 21:42:27 UTC
Type: ---


Attachments (Terms of Use)
Patch bumping to 1.3.3c and adding mod_geoip-0.2 (3.79 KB, patch)
2010-10-30 03:36 UTC, Philip Prindeville
no flags Details | Diff
Patch bumping to 1.3.3c and adding mod_geoip-0.2 (3.75 KB, patch)
2010-10-31 19:46 UTC, Philip Prindeville
no flags Details | Diff

Description Philip Prindeville 2010-10-30 03:36:03 UTC
Created attachment 456598 [details]
Patch bumping to 1.3.3c and adding mod_geoip-0.2

Description of problem:

New release of proftpd.

Version-Release number of selected component (if applicable):

1.3.3c

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Philip Prindeville 2010-10-31 19:46:04 UTC
Created attachment 456749 [details]
Patch bumping to 1.3.3c and adding mod_geoip-0.2

Comment 2 Fedora Update System 2010-11-02 16:28:53 UTC
proftpd-1.3.3c-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/proftpd-1.3.3c-1.fc14

Comment 3 Fedora Update System 2010-11-02 16:29:02 UTC
proftpd-1.3.3c-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/proftpd-1.3.3c-1.fc13

Comment 4 Fedora Update System 2010-11-03 14:38:56 UTC
proftpd-1.3.3c-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/proftpd-1.3.3c-1.fc12

Comment 5 Fedora Update System 2010-11-03 14:39:05 UTC
proftpd-1.3.3c-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/proftpd-1.3.3c-1.el5

Comment 6 Fedora Update System 2010-11-03 14:39:14 UTC
proftpd-1.3.3c-1.el4 has been submitted as an update for Fedora EPEL 4.
https://admin.fedoraproject.org/updates/proftpd-1.3.3c-1.el4

Comment 7 Philip Prindeville 2010-11-05 02:15:21 UTC
Minor change:

In /etc/sysconfig/proftpd I would add "-DGEOIP" to the list of commented out options for PROFTPD_OPTIONS.

Assuming most people use <IfDefine> and not <IfModule>, of course.

Just trying to follow the example that DYNAMIC_BAN_LISTS uses.

Comment 8 Philip Prindeville 2010-11-05 02:16:30 UTC
(In reply to comment #7)
> Minor change:
> 
> In /etc/sysconfig/proftpd I would add "-DGEOIP" to the list of commented out
> options for PROFTPD_OPTIONS.
> 
> Assuming most people use <IfDefine> and not <IfModule>, of course.
> 
> Just trying to follow the example that DYNAMIC_BAN_LISTS uses.

Except that there's no commented out example in /etc/proftpd.conf... Never mind.

Comment 9 Paul Howarth 2010-11-05 09:43:18 UTC
I did it that way because the idea of enabling things in /etc/sysconfig/proftpd was to be able to enable features without needing to touch /etc/proftpd.conf (and hence end up with a .rpmnew file on upgrades). That wouldn't apply in mod_geoip's case because it would always need some site-specific configuration and hence edits to /etc/proftpd.conf.

Comment 10 Fedora Update System 2010-11-10 21:42:17 UTC
proftpd-1.3.3c-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-11-10 21:46:41 UTC
proftpd-1.3.3c-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-11-11 22:15:16 UTC
proftpd-1.3.3c-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-11-19 18:32:34 UTC
proftpd-1.3.3c-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-11-19 18:32:56 UTC
proftpd-1.3.3c-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.