Bug 647992 - NetworkManager brings eth0 down until I login to X
Summary: NetworkManager brings eth0 down until I login to X
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-30 10:42 UTC by Chris Rankin
Modified: 2011-04-12 21:28 UTC (History)
2 users (show)

Fixed In Version: NetworkManager-0.8.3.996-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-02 01:50:56 UTC


Attachments (Terms of Use)
Configuration file for eth0 (387 bytes, text/plain)
2010-11-22 20:37 UTC, Chris Rankin
no flags Details
/var/log/messages (90.06 KB, text/plain)
2010-11-22 20:41 UTC, Chris Rankin
no flags Details
extra static route for eth0 (38 bytes, text/plain)
2010-11-23 21:17 UTC, Chris Rankin
no flags Details

Description Chris Rankin 2010-10-30 10:42:43 UTC
Description of problem:
NetworkManager tears down the wired eth0 interface when it loads, unless it has been told not to manage the interface at all. It then brings the interface up again after I login to X. However, this also completely prevents me logging in remotely via ssh should X fail to start for any reason, because eth0 is no longer up!

If I tell NetworkManager to keep its fumbling paws off eth0 then I can ssh into the PC, but then NetworkManager will no longer let me create VPN connections from the desktop.

Version-Release number of selected component (if applicable):
NetworkManager-0.8.1-9.git20100831.fc13.i686

How reproducible:
All the frigging time!!!

Steps to Reproduce:
1. Configure the eth0 interface to be managed by NetworkManager.
2. Boot the PC, but do not login to X.
3. Try creating a remote ssh session into the PC.

Actual results:
ssh does not connect, because there is "No route to host". 

Expected results:
A remote ssh session, so that I can perform emergency maintenance of (say) misbehaving X. And the ability to create VPN connections after I login to X so that I can do some work!

Additional info:
The "Activate device when computer starts" box is ticked, but doesn't help.

Comment 1 Jirka Klimes 2010-11-22 08:17:46 UTC
(In reply to comment #0)
> Description of problem:
> NetworkManager tears down the wired eth0 interface when it loads, unless it has
> been told not to manage the interface at all. It then brings the interface up
> again after I login to X. However, this also completely prevents me logging in
> remotely via ssh should X fail to start for any reason, because eth0 is no
> longer up!
> 
NetworkManager should read ifcfg-* files (if ifcfg-rh plugin is used, which is default) and should activate connections automatically when ONBOOT=yes.

To figure out what's wrong, post your /etc/sysconfig/network-scripts/ifcfg-eth0 and /var/log/messages files, please.

> Additional info:
> The "Activate device when computer starts" box is ticked, but doesn't help.
This indicates that you use system-config-network to configure interfaces. Nothing wrong with that, however NM ships with it's own tool 'nm-connection-editor' designed to edit its connections.

Comment 2 Chris Rankin 2010-11-22 20:37:55 UTC
Created attachment 462135 [details]
Configuration file for eth0

Comment 3 Chris Rankin 2010-11-22 20:41:38 UTC
Created attachment 462136 [details]
/var/log/messages

>> error: Missing or invalid IP4 gateway address '0'

Does NetworkManager hate static IP addresses, or something?

There's also a lot of noise about not being able to resolve various DNS names, which are probably because I have an upstream local name server that I don't know to configure for DNSSEC validation.

Comment 4 Jirka Klimes 2010-11-23 10:23:04 UTC
>> error: Missing or invalid IP4 gateway address '0'
indicates there a problem with the gateway of a static route, probably (missing GATEWAY0).

Please, post your /etc/sysconfig/network-scripts/route-eth0

It should contain static routes configuration like this:
ADDRESS0=192.168.0.0
NETMASK0=255.255.255.0
GATEWAY0=192.168.0.1

See the description in /usr/share/doc/initscripts-9.20.1/sysconfig.txt

> Does NetworkManager hate static IP addresses, or something?
By no means :)

BTW, you have invalid WEP key in key-wlan0
> ifcfg-rh:     error: Invalid WEP key length.
It should be some of these:
* WEP passphrase - string up to 63 characters
* WEP hex key    - string of hexadecimal chars of length 10 or 26
* WEP ascii key  - s: followed by 5 or 13 characters

Comment 5 Chris Rankin 2010-11-23 21:17:48 UTC
Created attachment 462451 [details]
extra static route for eth0

This route-eth0 file gives me the following routing table:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0
224.0.0.0       0.0.0.0         240.0.0.0       U     0      0        0 eth0
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0

which works fine.

Comment 6 Jirka Klimes 2010-11-24 16:34:26 UTC
(In reply to comment #5)
> Created attachment 462451 [details]
> extra static route for eth0
The error was caused by missing GATEWAY0 line.

However, thinking more about it and checking the initscripts behaviour, the missing GATEWAY0 should be regarded as 0.0.0.0
Moreover, ifcfg-rh plugin now refuses the explicit GATEWAY0=0.0.0.0

Both issues has been fixed upstream:
690357116017c190aab0cfed7612c3b16cb269df (master)
5afc5554f30a8f7bc2ce319fe1aed43e7769b358 (NM_0_8)

Comment 7 Chris Rankin 2010-11-24 16:54:45 UTC
(In reply to comment #6)
> The error was caused by missing GATEWAY0 line.

IIRC, this route-eth0 file was generated by either NM or sysconfig, and is correct for a multicast route anyway. (Although I do seem to remember fighting with the application at some point. Have you tried adding a multicast route to an interface via either GUI application recently?)

Comment 8 Fedora Update System 2011-02-24 06:06:22 UTC
NetworkManager-0.8.3.995-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc14

Comment 9 Fedora Update System 2011-02-24 06:09:49 UTC
NetworkManager-0.8.3.995-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc13

Comment 10 Fedora Update System 2011-02-24 20:57:32 UTC
NetworkManager-0.8.3.995-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.995-1.fc14

Comment 11 Fedora Update System 2011-02-25 23:43:08 UTC
Package NetworkManager-0.8.3.996-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc14
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2011-02-25 23:46:08 UTC
Package NetworkManager-0.8.3.996-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc13
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2011-03-02 01:49:32 UTC
NetworkManager-0.8.3.996-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2011-03-03 09:47:40 UTC
Package NetworkManager-0.8.3.997-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.997-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.997-1.fc13
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2011-03-25 03:30:36 UTC
NetworkManager-0.8.3.998-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.998-2.fc13

Comment 16 Fedora Update System 2011-04-12 21:28:22 UTC
NetworkManager-0.8.3.998-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.