Bug 64801 - changing to console1 from console 7 causes logout or kdm restart
changing to console1 from console 7 causes logout or kdm restart
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-12 20:19 EDT by Terry Davis
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-05 16:11:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 Log (25.19 KB, text/plain)
2002-05-13 03:06 EDT, Terry Davis
no flags Details
XFree86 config file (3.66 KB, text/plain)
2002-05-13 03:06 EDT, Terry Davis
no flags Details

  None (edit)
Description Terry Davis 2002-05-12 20:19:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2)
Gecko/20020510

Description of problem:
I use KDE, and kdm, have not tested this with gdm.  If I login to KDE and then
after a while switch to console 1 with CTRL+ALT+F1, something happens and my
original X console (7) is logged out or restarted because I will have a kdm
login screen again.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login to kdm
2. Switch to console 1
3. Wait a while ( over 30 minutes from my testing )
4. Check back with computer.
	

Actual Results:  You will see login screen of kdm.

Expected Results:  I expect it to be where I left off, logged into kde.

Additional info:
Comment 1 Mike A. Harris 2002-05-13 03:03:37 EDT
Attach your X server log, and config file please.
Comment 2 Terry Davis 2002-05-13 03:06:22 EDT
Created attachment 57064 [details]
XFree86 Log
Comment 3 Terry Davis 2002-05-13 03:06:56 EDT
Created attachment 57065 [details]
XFree86 config file
Comment 4 Mike A. Harris 2002-08-07 22:26:45 EDT
This sounds like a VTswitch problem, either with switching out of, or
switching into X with Intel i8x0 hardware.  If the X server crashes
when xdm/kdm/gdm are used, then it will be restarted which is why you
are getting a fresh login window.

I recommend using runlevel 3 by changing initdefault in /etc/inittab to 3,
and starting X by using "startx".  Once you switch away from X and observe
a crash of the X server, save a copy of the X log file WITHOUT starting
up the X server again.  Attach that log file to the bug report.  Make
sure you're attaching the log from the crash, and not a log from the
currently running X session.
Comment 5 Mike A. Harris 2002-09-05 16:11:46 EDT
Does this problem still occur with all of our rpm package updates applied
that have been released as erratum to date?  In particular our latest
kernel RPM?
Comment 6 Mike A. Harris 2002-11-04 03:34:39 EST
There is a bug in the i810 driver which the Intel driver author broke
the kernel ABI and did not change the version.  This causes various
weird problems to occur.  Our latest kernel contains a hack workaround
for this problem that there is no real way of fixing 100%.  People
whom have properly installed our newest kernel, and have things configured
correctly, do not experience these types of problems anymore.

I'm assuming you've done so as well due to lack of response to my last
two queries, so I'm closing this bug report as fixed.  The problem
doesn't occur in Red Hat Linux 8.0, so I'm closing with resolution
of CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.