Bug 648018 - useradd can not manage all components from /etc/skel
useradd can not manage all components from /etc/skel
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
13
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-30 09:46 EDT by Sergei LITVINENKO
Modified: 2010-11-25 06:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-25 06:14:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergei LITVINENKO 2010-10-30 09:46:11 EDT
Description of problem:

useradd can not manage all parts of /etc/skel

Version-Release number of selected component (if applicable):
shadow-utils-4.1.4.2-8.fc13.i686
libgnome-2.30.0-1.fc13.i686

How reproducible:
100%

Steps to Reproduce:
1. useradd testuser
2.
3.
  
Actual results:
error message
useradd: preserving permissions for /home/testuser/.gnome2: Operation not supported
Creating mailbox file: File exists

Expected results:
useradd manage all skel components.

Additional info:

two different installations of F13 shows the same error message.
one installetion with selinux and second without selinux.

[root@homedesk home]# rpm -qf /etc/skel/.gnome2 
libgnome-2.30.0-1.fc13.i686

[root@homedesk home]# rpm -V libgnome-2.30.0-1.fc13.i686
Comment 1 Peter Vrabec 2010-11-23 05:22:27 EST
Sorry I can't reproduce it.

$ getfacl /etc/skel/.gnome2/
# file: etc/skel/.gnome2/
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

Note You need to log in before you can comment on or make changes to this bug.