Bug 648099 - (ghc-http-enumerator) Review Request: ghc-http-enumerator - Haskell http-enumerator
Review Request: ghc-http-enumerator - Haskell http-enumerator
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
NotReady
:
Depends On: 630223 630274 648093 648097 648098 ghc-attoparsec-enum 746942 ghc-zlib-enum
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-30 18:03 EDT by Ben Boeckel
Modified: 2012-07-20 22:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-20 22:07:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Boeckel 2010-10-30 18:03:40 EDT
Spec URL: http://benboeckel.net/packaging/ghc-http-enumerator/ghc-http-enumerator.spec
SRPM URL: http://benboeckel.net/packaging/ghc-http-enumerator/ghc-http-enumerator-0.2.0.2-1.fc14.src.rpm
Description:
This package uses attoparsec for parsing the actual contents
of the HTTP connection. The only gotcha is the
withHttpEnumerator function, otherwise should do exactly what
you expect.

% lintmock fedora-14-x86_64-bb
ghc-http-enumerator.src: W: spelling-error Summary(en_US) Haskell -> Gaskell, Gaitskell, Skellum
ghc-http-enumerator.src: W: spelling-error %description -l en_US attoparsec -> megaparsec, ectoparasite, attorneyship
ghc-http-enumerator.src: W: spelling-error %description -l en_US withHttpEnumerator -> enumerator, numerator, enumeration
ghc-http-enumerator.src: W: strange-permission ghc-http-enumerator.spec 0640L
ghc-http-enumerator.src: W: strange-permission http-enumerator-0.2.0.2.tar.gz 0640L
ghc-http-enumerator.x86_64: W: spelling-error Summary(en_US) Haskell -> Gaskell, Gaitskell, Skellum
ghc-http-enumerator.x86_64: W: spelling-error %description -l en_US attoparsec -> megaparsec, ectoparasite, attorneyship
ghc-http-enumerator.x86_64: W: spelling-error %description -l en_US withHttpEnumerator -> enumerator, numerator, enumeration
ghc-http-enumerator-devel.x86_64: W: spelling-error %description -l en_US attoparsec -> megaparsec, ectoparasite, attorneyship
ghc-http-enumerator-devel.x86_64: W: spelling-error %description -l en_US withHttpEnumerator -> enumerator, numerator, enumeration
ghc-http-enumerator-prof.x86_64: E: devel-dependency ghc-http-enumerator-devel
ghc-http-enumerator-prof.x86_64: W: spelling-error %description -l en_US attoparsec -> megaparsec, ectoparasite, attorneyship
ghc-http-enumerator-prof.x86_64: W: spelling-error %description -l en_US withHttpEnumerator -> enumerator, numerator, enumeration
ghc-http-enumerator-prof.x86_64: W: no-documentation
ghc-http-enumerator-prof.x86_64: W: devel-file-in-non-devel-package /usr/lib64/ghc-6.12.3/http-enumerator-0.2.0.2/libHShttp-enumerator-0.2.0.2_p.a
4 packages and 0 specfiles checked; 1 errors, 14 warnings.
Comment 1 Jens Petersen 2011-06-21 21:28:33 EDT
http-enumerator >= 0.4.0 doesn't depend any more on HSOpenSSL
(seems to use tls instead).
Comment 2 Jens Petersen 2011-09-21 10:34:49 EDT
Current version is 0.7.1, authenticate needs >=0.6.5.4.
Comment 3 Jens Petersen 2012-04-16 05:51:45 EDT
authenticate >= 0.8 uses http-conduit instead.

Probably this is no longer needed: http://packdeps.haskellers.com/reverse/http-enumerator
Comment 4 Ben Boeckel 2012-07-20 22:07:22 EDT
Upstream marked this as obsolete. Closing.

Note You need to log in before you can comment on or make changes to this bug.