Bug 64811 - Error message on ifup with Orinoco driver
Error message on ifup with Orinoco driver
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 00:13 EDT by Matthew Saltzman
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-22 00:29:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2002-05-13 00:13:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Executing ifup on interface with Orinoco driver results in error message (but
interface comes up OK).

This is a Dell Latitude C610 with built-in ethernet (eth0 non-pc-card) and
built-in wireless (eth1 orinoco driver).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ifup eth1



Actual Results:  # ifup eth1
Error for wireless request "Set Mode" (8B06) 
    SET failed on device eth1 ; Invalid argument.
Determining IP information for eth1... 

Expected Results:  # ifup eth1
Determining IP information for eth1... 

Additional info:
Comment 1 Arjan van de Ven 2002-06-03 15:05:13 EDT
Bill: do you have any idea where this is comming from?
Comment 2 Bill Nottingham 2002-06-03 17:00:58 EDT
It's coming when the wireless tools set the parameters; it's either a driver bug
or a tools bug.
Comment 3 Manuel "Chilli" Chakravarty 2002-07-09 08:41:14 EDT
I am seeing a slightly different problem (but maybe related?) with the Orinoco
driver.  On a Dell C400 with TrueMobile builtin wireless, I get 

  eth1: Tx error, status 1 (FID=0135)

(where the FID varies).  These errors only appear occasionally, but once in a
while (after a couple of hours of operation) the card even hangs and I have to
bring the interface down and up again.

In addition, on my desktop machine, which has a Orinoco PCMCIA card via a
PCI-to-PCMCIA adapter, I get (in addition to the above error) occassionally a

  eth2: error -5 reading frame header. Frame dropped.
Comment 4 Manuel "Chilli" Chakravarty 2002-07-12 05:54:51 EDT
I replaced the orinoco-related modules that came with the kernel rpm for
2.4.18-3 by the newer driver version 0.12a that can be obtained from

  http://ozlabs.org/people/dgibson/dldwd/orinoco-0.12a.tar.gz

(This is the download site of the author of the driver.)  This fixed the
problems that I saw earlier.

NB: The Makefile included in the orinoco tar ball may be used to compile the
driver modules without the need to recompile the kernel (the kernel source rpm
has to be installed, of course).
Comment 5 Matthew Saltzman 2002-07-25 18:48:50 EDT
Also happens with the wavelan_cs driver.  I had configured the orinoco driver by
hand, but when I ran through the standard setup procedure, it selected the
wavelan_cs driver.  Using it produces the same message as originally reported
with the orinoco driver.  I conclude that either the two drivers share the same
code or the bug is tool-related rather than driver-related.
Comment 6 Richard Torkar 2003-01-22 06:08:43 EST
Same thing happens in latest Phoebe beta.

I used orinoco-0.13 and then it works. I got several insmod errors when trying
to load orinoco.

/Richard
Comment 7 Matthew Saltzman 2003-01-22 07:44:43 EST
In fact, currently in Psyche (and I don't know exactly what changed between my
last post and now):

[mjs@paladin mjs]$ ifup eth1
Error for wireless request "Set Mode" (8B06) :
    SET failed on device eth1 ; Invalid argument.
Error for wireless request "Set Frequency" (8B04) :
    SET failed on device eth1 ; Operation not supported.

Determining IP information for eth1... done.
Comment 8 Thomas 2003-09-19 02:43:17 EDT
I get the same problem with RH9. When i try to make orinoco 0.13e i get this error:

make -C /lib/modules/2.4.20-8/build SUBDIRS=/root/orinoco-0.13e modules
make: *** /lib/modules/2.4.20-8/build: No such file or directory.  Stop.
make: *** [modules] Error 2

what's the problem?
Comment 9 Bill Nottingham 2003-09-19 10:29:10 EDT
Do you have kernel-source installed?
Comment 10 Thomas 2003-09-20 02:22:53 EDT
Hi, again, sorry but I am having trouble installing the kernel source. I
gunzipped and untarred my kernel source (2.4.2) into /usr/src/linux-2.4.2 and
made a symbolic link with linux to linux-2.4.2 but when I run the make for
orinco-0.13e i still get the same error.
Comment 11 Thomas 2003-09-20 15:43:13 EDT
NM, I got it to work after installing 0.13e.

It also appears that Psyche does not support wireless encryption? (I had to
disable it to get it to work).
Comment 12 Matthew Saltzman 2003-09-20 16:17:55 EDT
I had no problem with wireless encryption in Psyche (but I'm up to Shrike on
that system now).  There are some issues with string keys vs hex keys that
appear elsewhere in Bugzilla and have been fixed in the latest
redhat-config-network.

That's kind of OT for this bug, though.
Comment 13 Bill Nottingham 2003-09-22 00:29:51 EDT
OK, closing as fixed in the current beta snapshots.

Note You need to log in before you can comment on or make changes to this bug.