Bug 64812 - largefile support is missing
largefile support is missing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 00:18 EDT by Kjetil T. Homme
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 03:42:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kjetil T. Homme 2002-05-13 00:18:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020430

Description of problem:
Perl can not open large files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. make large file somehow:
$ ls -lh /var/spool/news/cnfs/big1 
-rw-r--r--    1 news     news         5.0G May 13 06:14 /var/spool/news/cnfs/big1

2. enter oneliner:
$ perl -e 'open(F, "/var/spool/news/cnfs/big1") || die "$!\n";'
File too large



Expected Results:  the script should have terminated without error.

Additional info:

$ rpm -q perl
perl-5.6.1-34.99.6
Comment 1 Nathan G. Grennan 2002-05-13 03:42:26 EDT
Yeah, largefile support doesn't seem to work with perl-5.6.1-34.99.6 from RedHat
7.3. perl -V reports    -Uuselargefiles   but it doesn't seem to help. The below
url is a link to a mailing list thread that mentions this problem in previous
verions of RedHat.

http://archive.develooper.com/perl5-porters@perl.org/msg63296.html
Comment 2 Chip Turner 2002-05-13 10:45:52 EDT
-Uuselargefiles means to UNdefine it; -Duselargefiles defines it.  since large
file support breaks binary compatibility, and since 7.0 shipped without large
file support for perl, the 7.x series must ship without it.  If you click
further into the thread you quote, you'll see this post, which should help
explain it more:

http://archive.develooper.com/perl5-porters@perl.org/msg63385.html

Note You need to log in before you can comment on or make changes to this bug.