Bug 64817 - cant install harddrive on ide location used for cdrom to install
cant install harddrive on ide location used for cdrom to install
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 02:07 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-24 16:35:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-13 02:07:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
This bug was reproducable everytime.  At first i thought i had a bad drive.  i 
had my hd in hda and my cdrom in hdc.  After installing i removed the cdrom and 
put 3 more hd's in the machine.  The drive on hdc could not be used.  I even 
tried putting a different drive there, and installing with cdrom on hdb, then 
the hd that would be on hdb after install wouldnt work.  Eventually resolved by 
doing a ftp network install.  When trying to mount i would get an unable to 
access /dev/hdc error. and when doing a fdisk /dev/hdc it would give me a 
floppy-ide or ide-flopy no driver found error.  I cant remember it word for 
word the machine isnt in front of me atm.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install with cdrom on hdc
2.after install put a hd on hdc
3.try to use it
	

Actual Results:  Cant access drive

Expected Results:  Expected the drive to work

Additional info:

After installing with a network install the system worked as expected.  I tried 
multiple installs whereever the cdrom was installed at install time i woudl be 
unable to install a harddrive there.
Comment 1 Michael Fulbright 2002-05-13 15:08:13 EDT
I'm glad you were able to get the network install to work.  Could you give more
info on what types of IDE interfaces you have, from your information so far it
sounds like a hardware issue and not an installer issue, since you did get the
network install to work.
Comment 2 Need Real Name 2002-05-13 18:55:36 EDT
The only reason I placed it under the anaconda component was that it involved a 
cdrom based install.  The motherboard is a tyan tomcan 810ef.  And it work 
working fine in the exact same configuration with 6.2 through 7.2.  I did a 
clean install of 7.3 and that happened.  Whereever the cdrom was at install 
time I was unable to put a drive there.  It would detect the drive at boot as a 
maxtor and its model number.  However when i would go to access it via fdisk or 
mount I recieved that error.  I verified it wasnt just hdc by trying on hdb 
same results. And i verified it wasnt a bad drive by trying that drive in a 
different box as well as switchin hdd with hdc.  The other drive on hdc was no 
longer accessable as soon as it was on the ide controller that i had the cdrom 
on during the install.  I figured if its where the cdrom was during install I 
wouldnt wait for a patch and just try a network install.  I was able to get the 
system working like normal by using the network install.
Comment 3 Michael Fulbright 2002-05-23 15:43:30 EDT
Now your system is installed can you mount the cd drive?
Comment 4 Need Real Name 2002-05-24 16:35:49 EDT
Now the system is up with 4 ide drives because I installed via the ftp 
install.  When I installed with the cdrom install, I could mount a cdrom.  
However if i place a harddrive there instead of a cdrom i could not mount the 
drive.
Comment 5 Michael Fulbright 2002-06-12 12:49:32 EDT
Thanks for the feedback - I do not think this is a issue we can resolve since
its related to your specific hardware.
Comment 6 Need Real Name 2002-06-20 13:29:31 EDT
I really dont think it is the fault of my specific hardware.  If i take 6.2, 
7.0 , 7.1 or a 7.2 cd set and install it works fine.  It was only when i tried 
a clean install of 7.3 that the problem arised.

Note You need to log in before you can comment on or make changes to this bug.