Bug 64823 - rotate option doesnt work in resolv.conf
rotate option doesnt work in resolv.conf
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 03:21 EDT by Terry Davis
Modified: 2016-11-24 10:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 13:32:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Davis 2002-05-13 03:21:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2)
Gecko/20020510

Description of problem:
I cannot get the 'rotate' option to work in resolv.conf.  I have tried this on
6.2,7.1,7.2, and now 7.3 and it still doesnt work.  resolv.h has references to
it, however.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Enter 'options rotate' in resolv.conf
2.  Try query
	

Actual Results:  It always queries your first server first.

Expected Results:  It should round-robin your dns servers.

Additional info:

Here is my config:

domain domain.com
nameserver 10.10.1.5
nameserver 10.10.1.8
options rotate
search domain.com

On another note, some options DO work.  timeout works great. :)
Might also want to update man page so that it says HOW to notate multiple options...
should they be comma delimited?
"options timeout:1,rotate"
Or space delimited?
"options timeout:1 rotate"

Thank you
Comment 1 Ulrich Drepper 2003-04-23 03:47:34 EDT
Try this again with RHL9.  We had some changes in this area of the code on May
31st 2002.
Comment 2 David Mendelsohn 2003-09-05 08:35:35 EDT
I've tried this on RH9, RHES 2.1, and RHES 3.0 Beta.  It still doesn't function.

I found an old mailing list entry where Jakub had posted a patch, but it 
doesn't appear to be applied or it didn't function correctly.


Comment 3 Jakub Jelinek 2003-09-05 08:49:19 EDT
Well, it certainly works for me just fine.
Tried a program with 3 different gethostname() calls in it, 3 different nameservers
in resolv.conf. Without options rotate, in strace output it always queried the
first one, with that option it queried for each query a different one.
Comment 4 David Mendelsohn 2003-09-05 09:17:39 EDT
DIG, nslookup, and squid always select the first nameserver, with and 
without "options rotate".  

This is with a straight load of RH9.
Comment 5 Jakub Jelinek 2003-09-05 09:23:21 EDT
nslookup and dig are uninteresting, they don't use glibc but roll their own.
With squid, you were trying just one lookup per program invocation or more
lookups during the runtime of the program? RES_ROTATE will choose always the same
nameserver for the first lookup, then rotate by one, etc.
Comment 6 Ulrich Drepper 2003-10-03 05:56:08 EDT
Is this fixed?  Can I close the bug?  I'll do it if I don't hear anyhting in the
next days.
Comment 7 Ulrich Drepper 2003-11-05 13:32:02 EST
No response.  Closing.

Note You need to log in before you can comment on or make changes to this bug.