Bug 64832 - emacs requires X to install, despite its package description
emacs requires X to install, despite its package description
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 05:39 EDT by Ian Macdonald
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 05:39:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Macdonald 2002-05-13 05:39:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

Description of problem:
emacs requires X to install, despite references in its package description
(viewable with rpm -qi) to emacs-X11 and emacs-nox, both of which no longer
exist in Red Hat Linux 7.3.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. attempt to install emacs on a system without X libraries
2.
3.
	

Actual Results:  Emacs will not install and, if forced, will not start, due to
missing libraries.

Expected Results:  It should be possible to use Emacs on a system with no X
libraries installed.

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-05-13 12:07:57 EDT
The description you'll get when installing specspo (which contains the official
descriptions/summaries, the ones you'll see when installing) does not contain
these references.

Emacs now requires the X libraries, which is a separate, small package, to
install. Not an oversight, but a way to avoid duplicate packages.

Note You need to log in before you can comment on or make changes to this bug.