Bug 648357 - allow single Return to accept DHCP net config on stage1 network page
allow single Return to accept DHCP net config on stage1 network page
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-01 01:27 EDT by Jens Petersen
Modified: 2011-08-09 03:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-07 22:26:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2010-11-01 01:27:24 EDT
Description of problem:
It is annoying to have to press Tab 7 times
just to accept the default of dhcp networking.

How reproducible:
every time

Steps to Reproduce:
1. Boot boot.iso
2. Move through to "Configure TCP/IP" page
3. Try to press Return to move use DHCP.
  
Actual results:
2. Return key takes on through pages until net config page.
3. Have to press Tab 7 times first to get to the OK button

Expected results:
3. Return should accept default DHCP net settings
   and couple of Tab presses could take one to checkboxes
   if necessary.  Does newt support that?

Alternatively maybe add another screen
with two buttons for "DHCP" (default) and "Manual" config.
(I guess it would be pretty unusual to install
without network configuration these days.)
these days are seem small. :)
Comment 1 Chris Lumens 2010-11-01 10:34:21 EDT
Does F12 not take you to the next screen?  That should be documented on the screen somewhere.
Comment 2 Jens Petersen 2010-11-01 20:19:39 EDT
Doh - yes the F12 key is documented!  I had never noticed that... lol.
I see it even works in the GUI.

I still think Return would be good on the TUI network page though
since it is the last page before going to GUI, but I can't
really argue with [F12].
Comment 3 Chris Lumens 2010-11-02 10:16:50 EDT
I'll reassign this to Radek to see if he wants to do it.  I think other screens support moving forward with enter.
Comment 4 Dennis Appelon Nielsen 2011-08-07 17:16:54 EDT
Is this bug still relevant in recent Fedora releases ?
Please confirm...?
Comment 5 Jens Petersen 2011-08-07 22:26:36 EDT
I can't see any DHCP page any more by default in recent Fedora releases
so closing this out.
Shame I didn't note down what version I originally saw this on...
Comment 7 Radek Vykydal 2011-08-08 08:19:48 EDT
This is still present in Fedora. The fix is not as easy as it might appear. On the Configure TCP/IP screen the "Ok" and "Back" buttons are in a buttonbox which is part of a form (newt library components). Adding ENTER hotkey to the form would override ENTER on "Cancel" button. Maybe setting focus to "OK" is the way but if only I'd be able to do this in newt. I'd prefer to wait for the new UI in Fedora (http://fedoraproject.org/wiki/Anaconda/UX_Redesign).
Comment 8 Jens Petersen 2011-08-08 22:48:22 EDT
Right but now it only appears with "askmethod"?
Comment 9 Radek Vykydal 2011-08-09 03:41:20 EDT
In Fedora it should appear only if network needs to be enabled in loader (http://fedoraproject.org/wiki/Anaconda/Network#Network_enablement_in_installer, http://fedoraproject.org/wiki/Anaconda/Network#Loader_text_UI) or when using "asknetwork".

Note You need to log in before you can comment on or make changes to this bug.