Bug 648358 - [RFE] Add Devanagari Script Northern Variant in Lohit Devanagari Font
Summary: [RFE] Add Devanagari Script Northern Variant in Lohit Devanagari Font
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-devanagari-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-01 05:34 UTC by Ujjwol
Modified: 2012-12-24 08:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-24 08:01:26 UTC
Type: ---


Attachments (Terms of Use)
Chandas Uttara Sahadeva and Lohit Devangari (52.19 KB, image/png)
2010-11-01 05:34 UTC, Ujjwol
no flags Details
lohit (125.31 KB, patch)
2011-02-24 06:55 UTC, Sooraj kumar
no flags Details | Diff

Description Ujjwol 2010-11-01 05:34:32 UTC
Created attachment 456793 [details]
Chandas Uttara Sahadeva and Lohit Devangari

Description of problem:
The Lohit Devanagari currently uses the most popular variant - the southern variant of devanagari. But being the default font of fedora a popular os, it should also support the northern variant of devangari. This requires additions of newer glyph for:
अ आ ओ औ ऋ ॠ ण झ क्ष

My goal by asking this feature is to make Lohit Devanagari a full featured Devanagari font.
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I have attached the screenshot showing it in Chandas/Uttara - a GPL'ed font containing Northern Variant, and a free font Sahadeva containing Northern variant along with Lohit Hindi. Hope this will help.

Comment 1 Pravin Satpute 2010-11-01 06:49:45 UTC
I am really doubt full, by checking these shape, it clearly looks like we need a new Unicode points for these shapes.

It will be nice if you package Chandas/Uttara font for Fedora, if you need any help or any problem do let me know.

Adding these shapes in lohit will take some time, if someone want to volunteer/contribute in this i will surely help him.

Comment 2 Ujjwol 2010-11-01 07:01:10 UTC
No, we don't need new unicode points. This is not of a high priority so let us just leave it.

Comment 3 Ujjwol 2010-11-01 11:06:18 UTC
They just the variant, Chandas uses both variant in the same font. But as OpenOffice still doesnot support OT features, one could not use this.

Comment 4 Pravin Satpute 2010-11-02 04:23:28 UTC
OpenOffice supporting Open Type feature from long time.

Comment 5 Ujjwol 2010-11-02 04:29:49 UTC
OpenType fonts with the .otf extension doesn't even shows up. Alternative for same unicode points can't be done. It has many issues. http://www.openoffice.org/issues/show_bug.cgi?id=16032
I use other programs to access Open Type Features.

Comment 6 Pravin Satpute 2010-11-02 05:12:52 UTC
http://www.openoffice.org/issues/show_bug.cgi?id=16032


"OpenOffice (1.1.1) supports OpenType fonts with TrueType outlines (*.ttf ones,
like recent Times New Roman versions), but doesn't support OpenType fonts with
PostScript outlines (*.otf).
"

So yeah problem with .otf extentions font, but almost all feature are working with .ttf fonts.

Comment 7 Nicolas Mailhot 2010-11-02 13:35:21 UTC
The F14 OO.o version is supposed to support .otf, IIRC

Comment 8 Sooraj kumar 2011-02-24 06:55:07 UTC
Created attachment 480669 [details]
lohit

sooraj

Comment 9 Pravin Satpute 2011-02-24 07:17:39 UTC
Hi Sooraj,

 looks like problem with your attached .tar.gz file, can you attach signle .ttf or .sfd file?

Comment 10 Pravin Satpute 2012-12-24 08:01:26 UTC
Lohit fonts has some other priorities for coming years. Not looking any soonish to work on this. 

Closing as Deferred.


Note You need to log in before you can comment on or make changes to this bug.