Bug 64839 - wmaker does not honor rxvt size upon restart
wmaker does not honor rxvt size upon restart
Product: Red Hat Raw Hide
Classification: Retired
Component: WindowMaker (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-05-13 08:32 EDT by Mario Mikocevic
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-08-08 23:22:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mario Mikocevic 2002-05-13 08:32:14 EDT
This is getting worse by each rpm revision.

Description of Problem:
Latest rpm of WindowMaker does not honor rxvt size on startup.

  start rxvt, resize it to 90x60 for example, save WM session, restart WM,
  after restart rxvt window _will_ be 90x60 size but environment _inside_
  rxvt will be 80x24.

Version-Release number of selected component (if applicable):
# rpm -qa | grep Window
# rpm -qa | grep rxvt  

Additional info:
Is it maybe rxvt bug ? It worked before with same rxvt and WM-0.80.0-6 !
Comment 1 Phil Copeland 2002-08-05 16:36:28 EDT
Humm well I made a newer WindowMaker RPM set available in rawhide that should
compile across all 7.x/beta platforms


Give that a shot and see what happens

Comment 2 Phil Copeland 2002-08-05 16:40:10 EDT
(To be honest, this sounds more like a shopt problem... ie set 'shopt -c
checkwinsize' to run in /etc/profile somewhere)

Comment 3 Mario Mikocevic 2002-08-29 07:33:00 EDT
Ok, it works now but partialy.

And I don't think it's a shopt problem ->
# shopt -c checkwinsize 
zsh: command not found: shopt

  I don't run bash
  after I add `-title BLAH_BLAH` rxvts are _randomly_ _REPOSITIONED_
  even if I _don't_ touch their size
  yes, it _still_ _works_ if I reinstall WM-0.80.0-6 back
  with everything else the latest rawhide

my oppinion is that it _has_ to have something with `-title` option for rxvt.
The funniest thing is that after WM restart title is _not_ on the _proper_
rxvt but some other random one.

Comment 4 Phil Copeland 2002-08-29 12:44:36 EDT
Actually it's a bash shopt style problem IN zsh
not a windowmaker bug

Zsh sets LINES and columns to the value obtained from the TIOCGWINSZ
ioctl.  This way, when you resize you xterm, the LINES parameter will
change too.  Normally, when you resize your window, xterm sends SIGWINCH
to the process group of its terminal.  Zsh catches this signal, and
adjusts the window size.  So far so good, you do not resize you terminal,
so zsh does not get SIGWINCH, LINES should not change.  Unfortunately,
it's not that simple.  When zsh runs interactively, the MONITOR option is
enabled to allow you to use fg, bg, ^Z etc.  But this means that when you
start a foreground process, it will run in a separate process group from
zsh, and the terminal's process group is set to the foreground job's
process group.  As a consequence, zsh cannot handle the SIGWINCH signals
xterm sends when you resize the window, so when a foreground process
terminates, zsh goes and asks the terminal for its size.  If the terminal
says that it has 24 lines, zsh just assumes that it was resized, and
sets LINES to 24 even if you had set it to 31 before.

In short, you have two options
fix zsh
run bash with shopt -s checkwinsize (bash had exactly the same problem but the 
checkwinsize code was added to bash to get around this specific problem)

Comment 5 Mario Mikocevic 2002-08-29 13:38:58 EDT
Well, you almost completely misunderstud.
Try this ->

bash/zsh/whatever shell, just tried with bash and _the_ _same_ happened.
 - run wmaker
 - create at least three workspaces
 - open several rxvts, position them on different workspaces
now interesting part
 - start one rxvt with `-title BLAH` option and resize it
 - save workspace session
and THE most crucial part
 - exit wmaker
now goes *boom*
 - start wmaker again

title is on the _WRONG_ rxvt and on the workspace where you clicked
session save is default sized rxvt !

I think that this _IS_ definately a bug although I don't know is it WM's
or maybe rxvt's or even shell's !?

All that on latest rawhide !
Comment 6 Havoc Pennington 2004-08-08 23:22:53 EDT
WindowMaker has not been included for some time, closing bugs related to it.

Note You need to log in before you can comment on or make changes to this bug.