Bug 64852 - Non fatal Gtk errors when up2date hits a package already in its cache
Summary: Non fatal Gtk errors when up2date hits a package already in its cache
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-13 16:20 UTC by Alan Cox
Modified: 2015-01-07 23:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-15 06:27:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2002-05-13 16:20:58 UTC
If up2date hits a package during the download phase that is already cached, 
eg because /var/spool/up2date is shared, or from a prior up2date being killed
before finishing installing it prints

Gtk-CRITICAL **: file gtkprogress.c: line 518 (gtk_progress_set_percentage):
assertion `percentage >= 0 && percentage <= 1.0' failed.

for each such package.

This seems to have done no actual harm

Comment 1 Adrian Likins 2002-05-15 19:27:53 UTC
heh, lovely warning


Comment 2 Adrian Likins 2003-01-15 06:27:54 UTC
This is fixed in the 7.3 errata.


Note You need to log in before you can comment on or make changes to this bug.