Bug 64856 - PXE Kickstart Installation has serious problems
PXE Kickstart Installation has serious problems
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 13:05 EDT by Marc Schmitt
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-06 12:23:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kickstart file used for unattended installation over PXE. (949 bytes, text/plain)
2002-05-13 13:07 EDT, Marc Schmitt
no flags Details

  None (edit)
Description Marc Schmitt 2002-05-13 13:05:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
Running a kickstart installation with PXE reports many error messages on console
F4 and hangs forever during postinstall.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Kickstart with PXE
	

Actual Results:  The unattended installation starts and shows the following
error messages on console Alt-F4:

<6>attempt to access beyond end of device
<6>01:01: rw=1, want XXXX, limit 4608

Those two lines are repeated with incremental values for XXXX. The lowest value
for XXXX I could see on the console was 7418 (couldn`t scroll back more), it
went up to 7488.
Installation will run through then by installing RPMs. Once the postinstall
starts, the progress bar will hang at a little bit less than half and on console
F4 appear again the two famous lines mentioned above. The final value of XXXX is
now 4846.
Two more lines appear at the bottom of F4:

<4>Error -3 while decompressing! <4>c02a0a3c(-1296616283)->c4b2a000(4096)

Then nothing happens anymore.

Expected Results:  Installation should run through and finish by rebooting.

Additional info:

A side effect is, that once the installation hangs in the postinstall, not a
single command on console F2 can be executed anymore. All you will get is
"permission denied".

I tested it on two machines, one a standard PC and the other one a PE4600 from
Dell. I`ve installed both systems w/o any problems over PXE with RedHat 7.1,
many times.

To eliminate the possibility of a bug in the kickstart file, I copied it on a
bootnet floppy and run a "linux ks=floppy". Installation ran through flawlessly.
Comment 1 Marc Schmitt 2002-05-13 13:07:35 EDT
Created attachment 57104 [details]
Kickstart file used for unattended installation over PXE.
Comment 2 Marc Schmitt 2002-05-13 13:15:59 EDT
I forgot to mention that I tried both PXE initrds (initrd-everything.img and
initrd.img), the result was the same.
Comment 3 Jeremy Katz 2002-05-13 14:31:03 EDT
You need to be sure to pass ramdisk_size=8192 on the kernel command line from PXE.  

If that's not the problem, feel free to reopen the bug.
Comment 4 Marc Schmitt 2002-06-06 12:23:28 EDT
Hi,

Thanks for your quick answer!
ramdisk_size=8192 indeed fixed the "attempt to read beyond end of device"-problem.
Installations run through now. :)

The "Alt-F2"-problem remains, though, with a different error message. I get
"<command>: not found" for any <command> I enter except mknod (maybe there are
others, but it`s pretty tough to find anything with ls not working...).
Maybe the PATH ist just not set correctly?
echo $PATH works and returns:
/bin:/usr/bin:/usr/sbin:/usr/X11R6/bin:/mnt/sbin:/mnt/usr/sbin:/mnt/bin:/mnt/usr/bin

Doing a "chroot /mnt/sysimage" at the end of an installation to check if my
postinstall scripts worked etc. helped me a lot in the past and I`d gladly see
it working in RH7.3, too. Thanks.

Note You need to log in before you can comment on or make changes to this bug.