Bug 64873 - Please make rhn_register use intltool
Summary: Please make rhn_register use intltool
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-13 20:17 UTC by Christian Rose
Modified: 2015-01-07 23:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-13 20:17:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Rose 2002-05-13 20:17:37 UTC
Please consider making rhn_register use intltool. This will significantly ease
the translation of the .desktop file entries for translators, since they can be
translated and maintained directly from the po file.

Comment 1 Adrian Likins 2002-05-15 19:09:54 UTC
Will attempt to do this once some docs about using it on non auto* packages
appear.

Comment 2 Kenneth Rohde Christiansen 2002-05-15 19:29:09 UTC
1) create a file with one this like GETTEXT_PACKAGE=your_textdomain and place
it in the root and call it configure.in (this doesnt mean that you have to
use auto* or anything like that.

2) mkdir po/   

3) Create a file called POTFILES.in in po/ and add the .desktop.in in it/

4) Now run intltool-update --pot

5) Create a testing language, by copying your_textdomain.pot into the lang
file, like for instance 'cp footool.pot da.po', now update the language by
issuing 'intltool-update lang' ie. for Danish 'intltool-update da'

6) To create the .desktop file from the desktop.in file do the following:
intltool-merge -d -u PO_DIR filename.desktop.in filename.desktop, where po
dir is ../po if you for instance do this from src/

PLEASE IMPROVE THIS GUIDE!

Thanks, Kenneth
kenneth@gnu.org


Comment 3 Kenneth Rohde Christiansen 2002-05-15 19:31:08 UTC
Oops, please change this:

create a file with one this like GETTEXT_PACKAGE=your_textdomain 

to:

create a file with only this line: GETTEXT_PACKAGE=your_textdomain
(you could call your_textdomain for rhn_register in this case)


Note You need to log in before you can comment on or make changes to this bug.