Bug 648740 - Spellcheck in oowriter, gedit and abiword gives thousands of "error: line [x]: bad flagvector"
Summary: Spellcheck in oowriter, gedit and abiword gives thousands of "error: line [x...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hunspell
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-02 00:47 UTC by fropeter
Modified: 2010-11-14 21:29 UTC (History)
1 user (show)

Fixed In Version: hunspell-1.2.12-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-08 22:42:39 UTC
Type: ---


Attachments (Terms of Use)

Description fropeter 2010-11-02 00:47:45 UTC
Description of problem:

If spell check is on in oowriter, abiword or gedit (through gedit-plugins), and probably other programs as well(not tested), _thousands_ of errors occur when the spell check is executed. In oowriter and abiword this happens as the program is either opened with a file specified; or on a new file, when the first word is spell checked. In gedit it happens when the file is saved the first time after it is opened. Subsequent spell checks do not yield any such errors.

The error in question is 
    
    error: line [x]: bad flagvector

where [x] denotes a number between 1 and increasing upwards of 322000, intervals between numbers seemingly between 1 and 5.

If spell check is turned off, the errors do not occur.

All these three applications use hunspell for this functionality, as far as I can tell, so I suppose the problem belongs to that package.

This is on a Thinkpad R500, Intel Core2 duo, P8700, 4GB RAM, running Fedora 14 x86_64 beta, Gnome. Fresh install, continuously updated since install 14 days ago. The error has occurred since F14 was installed. I never experienced this on F12 on the same machine. (For reference, F14 will be launched in 1 or 2 days as this report is written.)
Current kernel is 2.6.35.6-48.fc14.x86_64.


Version-Release number of selected component (if applicable):
hunspell-1.2.12-1.fc14 (x86_64)


How reproducible:
Open affected application in terminal, either creating a new file or opening an existing file, somehow cause spell check to start, watch output in terminal.

Steps to Reproduce:
1.Open a terminal
2.Start affected application from terminal, with or without file name specified

a3. In oowriter or abiword, make shure automatic spell check is on
a4. type a word followed by a whitespace to initiate the spell check
a5. watch output in terminal window

b3. In gedit, make shure the spell check plugin is activated
b4. Write some text to mark the file as modified
b5. Save the file
b6. watch output in terminal window

  
Actual results:
Thousands of lines with the error message
    
    error: line [x]: bad flagvector

are generated.

Expected results:
No error messages

Additional info:
If the programs are started from the gui, you don't see the error messages, but the error feels like a delay in saving the document. I can't find the error in the logs.

Workaround: Disable spell check in the affected applications.

Comment 1 Caolan McNamara 2010-11-02 08:38:49 UTC
This indicates a problem in a specific dictionary. What's your language nb_NO, nb_NO or something like that ? The lines refer to the matching line in the .dic

Comment 2 Caolan McNamara 2010-11-02 12:52:14 UTC
Inspection shows that its nb_NO. 

As per http://spell-norwegian.alioth.debian.org/#Contact I tried to send a mail to https://lister.ping.uio.no/mailman/lister.ping.uio.no/listinfo/i18n-no with the plausible fix of sed -i -e "s#\/\$##g" nb_NO.dic in it

Comment 3 Fedora Update System 2010-11-02 12:57:53 UTC
hunspell-no-2.0.10-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/hunspell-no-2.0.10-7.fc14

Comment 4 fropeter 2010-11-02 19:15:26 UTC
Thank you for fixing this so fast! You're correct, my locale is nb_NO, but the language package on my system is called hunspell-nb (not -no), for norwegian-bookmaal. (There is also a package called hunspell-nn that belongs to the NO locale; norwegian-nynorsk).
I'll test again when I get the update.

Comment 5 Caolan McNamara 2010-11-02 20:16:23 UTC
Yeah, hunspell-no is the "parent" package and hunspell-nb hunspell-nn are the specific names of the subpackages for each language.

Comment 6 Fedora Update System 2010-11-02 22:19:07 UTC
hunspell-no-2.0.10-7.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hunspell-no'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/hunspell-no-2.0.10-7.fc14

Comment 7 fropeter 2010-11-03 16:52:13 UTC
I have tested the three apps (gedit, abiword, oowriter) after installing the update, and the problem is solved. No errors at all.
Thank you for the rapid fix of the problem!

Comment 8 Caolan McNamara 2010-11-05 21:10:04 UTC
Talking to some people the consensus now seems to be that the dic is legal to do that, and hunspell is overly complaining

Comment 9 Fedora Update System 2010-11-05 21:10:48 UTC
hunspell-1.2.12-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/hunspell-1.2.12-2.fc14

Comment 10 fropeter 2010-11-06 03:39:29 UTC
If I understand correctly, hunspell is now modified so that the original dictionary file is 'valid' again. Should I downgrade?

Comment 11 Caolan McNamara 2010-11-06 11:57:23 UTC
You can, that would help test this for me. I don't think it actually matters to the functionality of your dictionary however, it should give the same result either way I believe.

Comment 12 fropeter 2010-11-06 14:52:33 UTC
I have downgraded to hunspell-{nb,nn}-2.0.10-6.fc14 and installed hunspell-1.2.12-2.fc14.x86_64, and can confirm that the problem is fixed (on x86_64 at least). Thanks again!

Comment 13 Fedora Update System 2010-11-06 23:39:37 UTC
hunspell-1.2.12-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hunspell'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/hunspell-1.2.12-2.fc14

Comment 14 Fedora Update System 2010-11-08 12:02:48 UTC
hunspell-1.2.12-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/hunspell-1.2.12-3.fc14

Comment 15 Fedora Update System 2010-11-08 22:42:34 UTC
hunspell-1.2.12-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2010-11-14 21:28:56 UTC
hunspell-1.2.12-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.