Bug 64878 - Please make ksconfig use intltool
Please make ksconfig use intltool
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: ksconfig (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 16:18 EDT by Christian Rose
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-18 12:47:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2002-05-13 16:18:29 EDT
Please consider ksconfig use intltool. This will significantly ease the
translation of the .desktop file entries for translators, since they can be
translated and maintained directly from the po file.
Comment 1 Brent Fox 2002-05-28 12:30:46 EDT
We need to do this soon, but I don't have a current timetable for it.
Comment 2 Christian Rose 2002-11-09 07:12:17 EST
Don't know who closed this one, but I'd really like to know the reason.
Comment 3 Christian Rose 2003-01-18 06:29:43 EST
Why was this marked WONTFIX? No reason was given...
Comment 4 Brent Fox 2003-01-18 12:47:41 EST
Oh sorry.  Using intltool will require using autoconf, which to me is overkill
for a simple python program.
Comment 5 Kenneth Rohde Christiansen 2003-01-18 12:54:50 EST
Nope, it doesnt require use of the auto* tools. 

It really isnt that hard.

Create a po/ dir.
Add a po/POTFILES.in file, including the path to the somename.desktop.in file

Then to create the somename.desktop file all you do is:

$ intltool-merge po/ -d -u -c po/.intltool-merge-cache somename.desktop.in
somename.desktop

you can also type intltool-merge --help for a bit more info.

Note You need to log in before you can comment on or make changes to this bug.