Bug 64888 - Doesn't detect imbedded soundchip upon installation
Doesn't detect imbedded soundchip upon installation
Status: CLOSED DUPLICATE of bug 54905
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-13 17:45 EDT by Need Real Name
Modified: 2013-07-02 22:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-21 03:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of /sbin/lspci -v (3.10 KB, text/plain)
2002-05-14 14:10 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-05-13 17:45:09 EDT
Description of Problem: Installation doesn't detect sound of imbedded 5880 compatible chip


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. Install Linux
2. 
3. 

Actual Results:
Sound driver not installed, and complains upon shutting down that mixer services, etc are not installed, so fails when it trys to shut them down.

Expected Results:
Sound is expected

Additional Information:
I believe that I saw something on a news posting that said that that 5880 chip was compatible with the 3713 driver or something like that.  I just can't 
remember the specific number, or how to force it to install.  Thank you in advance, and I'll be happy to provide you with any and all information that 
you want.
Comment 1 Bill Nottingham 2002-05-13 17:49:13 EDT
lspci output?
Comment 2 Need Real Name 2002-05-14 14:10:45 EDT
Created attachment 57304 [details]
output of /sbin/lspci -v
Comment 3 Need Real Name 2002-05-14 14:13:03 EDT
Hmmmm, obviously the manufacturer of this computer identified the motherboard they used incorrectly, sorry for the mixup, seems that this is using an imbedded AC97 
chip.
Comment 4 Need Real Name 2002-10-19 17:08:20 EDT
Same with my new install of RH 8
Comment 5 Need Real Name 2002-10-19 17:08:31 EDT
Same with my new install of RH 8
Comment 6 Need Real Name 2002-10-19 17:10:38 EDT
Same with my new install of RH 8
Sound does not work. It appears to be properly detected however the following 
errors occur when loading KDE and after any reboot:

Informational - artsmessage (Window Title)

Sound server informational message:

Error while initializing the sound driver:

Device /dev/dsp can't be opened (No such device)

The Sound server will continue, using the null output device.  (OK button)

After installing sndconfig and running it I get:
      ┌────────────────────────┤ modprobe error ├────────────────────────
      │                                                                  │
      │ The following error occurred running the modprobe program:       │
      │                                                                  │
      │ /lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o:   │
      │ init_module: No such device                                      │
      │ /lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o:   │
      │ insmod                                                           │
      │ /lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o    │
      │ failed                                                           │
      │ /lib/modules/2.4.18-14/kernel/drivers/sound/via82cxxx_audio.o:   │
      │ insmod sound-slot-0 failed                                       │
      │                                                                  │
      │                             ┌────┐                               │
      │                             │ Ok │                               │
      │                             └────┘                               │
      │                                                                  │
      │                                                                  │
      └──────────────────────────────────────────────────────────────────┘
Here is some more info:

[keith@localhost sbin]$ ./lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8367 [KT266]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8367 [KT333 AGP]
00:08.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 42)
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. 
RTL-8139/8139C/8139C+ (rev 10)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233 PCI to ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE 
(rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. USB (rev 1b)
00:11.3 USB Controller: VIA Technologies, Inc. USB (rev 1b)
00:11.4 USB Controller: VIA Technologies, Inc. USB (rev 1b)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio 
Controller (rev 30)
01:00.0 VGA compatible controller: S3 Inc. Savage 4 (rev 02)
[keith@localhost sbin]$
Comment 7 Bill Nottingham 2002-10-21 00:32:47 EDT
kjwkea@mts.net: what you have is just a problem with the via driver, it's a
known issue with 8.0.

Original reporter: your chip *should* work with the via82cxxx_audio driver in
the errata kernel.
Comment 8 Jeff Garzik 2002-10-21 11:32:27 EDT

*** This bug has been marked as a duplicate of 54905 ***

Note You need to log in before you can comment on or make changes to this bug.