Bug 648930 - [MEMLEAK] gedit is 89Mb of RAM every time a 500byte file is opened
[MEMLEAK] gedit is 89Mb of RAM every time a 500byte file is opened
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
14
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-02 10:41 EDT by Thierry Vignaud
Modified: 2010-11-30 04:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-30 04:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thierry Vignaud 2010-11-02 10:41:58 EDT
Description of problem:
gedit is eating tons of Mb, allocating 89Mb every time
a 500byte file is opened

Version-Release number of selected component (if applicable):
gedit-2.30.4-1.fc14.x86_64
(FC14 updated this morning)

How reproducible:
Everytime


Steps to Reproduce:
1. start gedit, look at memory usage with "ps"
2. open a very small file (~512b), look again at memory usage
3. repeat 2, 3 times...
  
Actual results:
Every time a small file (less than 1kb!) is opened, gedit consistently use 69 more Mb of resident memory...

Expected results:
A reasonable amount of memory is used, slowly increasing as more files are opened in new tags.

Additional info:
fresh startup:
17531 a         20   0  613m  19m  13m S  0.0  1.0   0:00.33 gedit
after opening one small file (around 500bytes):
17531 a         20   0  682m  88m  14m S  0.0  4.5   0:01.04 gedit
after opening 2 small files:
17531 a         20   0  750m 157m  14m S  0.0  7.9   0:02.65 gedit
after opening 3 small files:
17531 a         20   0  819m 226m  14m S  0.0 11.4   0:04.21 gedit
after opening 4 small files:
17531 a         20   0  888m 294m  14m S  0.0 14.8   0:05.79 gedit

Each file was in the 500byte - 1.5kb, however gedit eats
69Mb for each new tab...
For a grand total of 275Mb of RAM in order to edit 4 very small files!
Comment 1 Thierry Vignaud 2010-11-30 04:56:44 EST
While it was reproducable for nearly a month, it looks like some update fixed it.

Note You need to log in before you can comment on or make changes to this bug.