Bug 648984 - F13 guest fails to run on RHEL5.x
Summary: F13 guest fails to run on RHEL5.x
Keywords:
Status: CLOSED DUPLICATE of bug 574621
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm
Version: 5.7
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Marcelo Tosatti
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: Rhel5KvmTier2
TreeView+ depends on / blocked
 
Reported: 2010-11-02 16:57 UTC by Juan Quintela
Modified: 2011-03-01 20:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-01 20:10:42 UTC


Attachments (Terms of Use)

Description Juan Quintela 2010-11-02 16:57:28 UTC
Description of problem:

F13 guest is unable to run or rhel5 kernel.

http://www.mail-archive.com/kvm@vger.kernel.org/msg30158.html

Version-Release number of selected component (if applicable):

all.

How reproducible:

always.

Steps to Reproduce:
1.  install F13 guest on F13, and then try to boot that image on rhel5.
  
Actual results:

crash with similar message to:
http://www.mail-archive.com/kvm@vger.kernel.org/msg30158.html

Expected results:

it works.

Additional info:

problem is with pvmmu support removed upstream.  Marcelo already have a way to fix this.

If fix is trivial, it should also be backported to zstream.

Comment 2 RHEL Product and Program Management 2011-01-11 20:16:33 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 3 RHEL Product and Program Management 2011-01-11 22:55:46 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 5 dawu 2011-01-31 07:57:51 UTC
Tested this bug on latest build kvm-83-224.el5,it does not exist any more, f13 installed on f13 host can be run on rhel5.6 without any error.

Comment 6 Miya Chen 2011-01-31 08:15:04 UTC
michen-->Juan
Based on comment#5, can you give us any suggestion on how to reproduce this? thanks.

Comment 7 Marcelo Tosatti 2011-02-22 20:49:01 UTC
(In reply to comment #6)
> michen-->Juan
> Based on comment#5, can you give us any suggestion on how to reproduce this?
> thanks.

Parameter ept=0 should be passed when loading kvm_intel.ko module.

Comment 8 Marcelo Tosatti 2011-02-23 19:58:13 UTC
Actually this should be fixed already by commit 62501ff6ab1a58aa1d on kvm-rhel5.git.

Comment 11 Glauber Costa 2011-03-01 20:10:42 UTC

*** This bug has been marked as a duplicate of bug 574621 ***


Note You need to log in before you can comment on or make changes to this bug.