Bug 64899 - Config doesn't find modem with port higher than ttyS3
Config doesn't find modem with port higher than ttyS3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-14 01:04 EDT by Need Real Name
Modified: 2014-03-16 22:27 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2.47-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 18:42:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modem probing script (131 bytes, text/plain)
2002-05-14 17:53 EDT, Trond Eivind Glomsrxd
no flags Details
modem test script (131 bytes, text/plain)
2002-05-14 17:56 EDT, Trond Eivind Glomsrxd
no flags Details

  None (edit)
Description Need Real Name 2002-05-14 01:04:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
In RH 7.1 using the config programs my modem is found on /dev/ttyS2.  In 7.3
it's not found at all by config-network.  It's an internal, hardware modem. 
After reinstalling 7.1 (to get a working reference point) and then reinstalling
7.3 and doing a bit of research with setserial I found the modem at /dev/ttyS4,
much to my surprise (didn't think that port existed).  Interestingly, the
hardware summary program doesn't show my modem either.

Using /dev/ttyS4 in redhat-network-config worked like a charm.  Perhaps a few
higher ttyS* numbers should be added to the scripts that find the modem and then
show the possible ports?  Or is this a problem elsewhere?  I had trouble
deciding if this was a kernel problem or not, but after all, the kernel knows
the modem is there, it's the config and other programs that don't.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Fresh install of RH 7.3 on reformatted drives
2.  Try to configure network/dialup
3.  Dialup won't find modem higher than ttyS3

To solve:
4.  use setserial -bg ttyS* to find actual modem port
5.  Enter port in config-network
6.  Works
	

Actual Results:  After I used setserial to find the port, it works fine. 
However, I don't think a newbie should be expected to know that.  It took me
reading up in an old networking manual to find the command I wanted, and I was
very determined (love 7.3, but really need my internet connection!).

Additional info:

This is a PenguinComputing Tempest computer:
AMD Athlon 1.3G
10/100 Ethernet Card
Internal Hardware Modem (sorry don't know the flavor)
Comment 1 Trond Eivind Glomsrxd 2002-05-14 17:53:15 EDT
Created attachment 57326 [details]
Modem probing script
Comment 2 Trond Eivind Glomsrxd 2002-05-14 17:56:46 EDT
Created attachment 57327 [details]
modem test script
Comment 3 Trond Eivind Glomsrxd 2002-05-14 17:58:12 EDT
Can you test the attached script (duped, didn't show up the first time) on your
system (as root) and return the result?
Comment 4 Need Real Name 2002-05-14 18:13:59 EDT
Tested:

The result is:
[root@lavender root]# ./modemtest
[]
[root@lavender root]# 

I haven't a clue what that means, I think I need to continue reading my python
manuals :).
Comment 5 Trond Eivind Glomsrxd 2002-05-14 18:22:59 EDT
It means that the probe code didn't find a modem. The probe code is part of
kudzu... reassigning.

Comment 6 Bill Nottingham 2006-08-24 18:42:15 EDT
Fixed in 1.2.47-1.

Note You need to log in before you can comment on or make changes to this bug.