Bug 648990 - llvm/Support/AlignOf.h fails to compile with C++0x
llvm/Support/AlignOf.h fails to compile with C++0x
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Bryan O'Sullivan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-02 13:04 EDT by Hicham HAOUARI
Modified: 2010-11-25 20:14 EST (History)
4 users (show)

See Also:
Fixed In Version: llvm-2.8-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-25 20:10:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hicham HAOUARI 2010-11-02 13:04:42 EDT
Description of problem:
This is a backport request of the patch in upstream http://llvm.org/bugs/show_bug.cgi?id=8423

Version-Release number of selected component (if applicable):
llvm-2.8-3


I need this patch to build lightspark
Comment 1 Michel Alexandre Salim 2010-11-12 10:14:46 EST
I've backported the relevant commits for LLVM and Clang, and everything seems to be in order. We're doing an LLVM update for F-14 and F-13 anyway because some packages now require LLVM 2.8, so this will go out then.

Rawhide build is in progress.
Comment 2 Fedora Update System 2010-11-12 11:02:00 EST
emacs-common-w3m-1.4.398-0.4.20100714cvs.fc14,pure-0.45-3.fc14,OpenGTL-0.9.15-1.fc14,llvm-2.8-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/emacs-common-w3m-1.4.398-0.4.20100714cvs.fc14,pure-0.45-3.fc14,OpenGTL-0.9.15-1.fc14,llvm-2.8-4.fc14
Comment 3 Fedora Update System 2010-11-12 11:02:13 EST
llvm-2.8-4.fc13,emacs-common-w3m-1.4.398-0.4.20100714cvs.fc13,OpenGTL-0.9.15-1.fc13,pure-0.45-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/llvm-2.8-4.fc13,emacs-common-w3m-1.4.398-0.4.20100714cvs.fc13,OpenGTL-0.9.15-1.fc13,pure-0.45-3.fc13
Comment 4 Fedora Update System 2010-11-13 17:04:09 EST
llvm-2.8-4.fc13, emacs-common-w3m-1.4.398-0.4.20100714cvs.fc13, OpenGTL-0.9.15-1.fc13, pure-0.45-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update llvm emacs-common-w3m OpenGTL pure'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/llvm-2.8-4.fc13,emacs-common-w3m-1.4.398-0.4.20100714cvs.fc13,OpenGTL-0.9.15-1.fc13,pure-0.45-3.fc13
Comment 5 Fedora Update System 2010-11-25 20:10:38 EST
emacs-common-w3m-1.4.398-0.4.20100714cvs.fc14, pure-0.45-3.fc14, OpenGTL-0.9.15-1.fc14, llvm-2.8-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2010-11-25 20:14:07 EST
llvm-2.8-4.fc13, emacs-common-w3m-1.4.398-0.4.20100714cvs.fc13, OpenGTL-0.9.15-1.fc13, pure-0.45-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.