Bug 64908 - Gnome games can't write scores to /var/games
Gnome games can't write scores to /var/games
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
7.3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
: 69394 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-05-14 06:26 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 13:42:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-14 06:26:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
Some games (I see it in gnome-games e.g same-gnome, gnomine) try write gamescore
to /var/games directory, but this directory don't exists. In rpm
filesystem-2.1.6-2 is defined directory /var/lib/games (with score files), but
not /var/games - it seems there is a mistake (in games or in filesystem)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start same-gnome game (from GNOME)
2.Play and win :-) 


Actual Results:  The game stop and in ~/.xsession-errors is message:
GnomeUI-WARNING **: Could not open help topics file NULL
/var/games/same-gnome.scores: No such file or directory


Expected Results:  They may apperar dialog with new gamescore

Additional info:
Comment 1 Havoc Pennington 2002-05-14 11:09:33 EDT
Yuck, not good. Probably just a mistake in the gnome-games spec file pointing 
the apps at the wrong scores directory.
Comment 2 Mihai Ibanescu 2002-06-25 10:37:19 EDT
Same goes for mahjongg, it tries to read the scores files from /var/games.
Comment 3 John MacLean 2002-07-22 21:40:45 EDT
I'm experiencing the same problem with all gnome-games. misa's comment provides
the hint to a workaround that does it for me. 
>su -c 'ln -s /var/lib/games /var/games'

Still need to create at least one high score in each game before Game/Scores
gives a popup (this might be normal behaviour, I don't know).
Comment 4 Preston Brown 2002-08-14 13:28:01 EDT
actually, this is a problem in libgnome, not gnome-games.
Comment 5 Elliot Lee 2002-08-21 13:30:37 EDT
Fixed in libgnome-2.0.2-4
Comment 6 Preston Brown 2002-08-21 13:42:04 EDT
*** Bug 69394 has been marked as a duplicate of this bug. ***
Comment 7 Jay Turner 2002-09-03 11:19:13 EDT
Fix confirmed with libgnome-2.0.2-5.

Note You need to log in before you can comment on or make changes to this bug.