Bug 649095 - Refuses to install to disks over 2^31 blocks in size [PATCH]
Refuses to install to disks over 2^31 blocks in size [PATCH]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Unspecified
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-02 19:03 EDT by Rob Spanton
Modified: 2011-03-07 13:14 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-15.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-03 14:09:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to use a long long int to store storage device size (2.10 KB, patch)
2010-11-02 19:03 EDT, Rob Spanton
no flags Details | Diff

  None (edit)
Description Rob Spanton 2010-11-02 19:03:57 EDT
Created attachment 457302 [details]
Patch to use a long long int to store storage device size

When preupgrading my machine, anaconda requested a "driver disk" for my machine (and wouldn't let me proceed without one).  I was confused, as my machine has no weird hardware in it, so I went on a debugging spree.

Turns out that it's a bug in the device listing code.  It was using a long int to store the size of a device.  My hard disk is just over this threshold, so it was b0rking at this.

Find a patch attached that fixes this issue.
Comment 1 Chris Lumens 2010-11-03 10:27:48 EDT
Do you know if parted and pyparted also support your device?  If not, you're just going to run into more problems later.
Comment 2 Rob Spanton 2010-11-03 11:21:37 EDT
Yes, parted supports this device.  It's how I partitioned it under F13.

Sorry, I should have been clearer.  This device is a 1.5TB hard disk.  It's not exotic or anything.

This bug is pretty serious, as it means that anyone with a 1.5TB hard disk cannot use preupgrade (it might also affect other methods of upgrade/installation, but I only preupgrade...).
Comment 3 Chris Lumens 2010-11-03 14:09:23 EDT
This will be included in the next build of anaconda for rawhide.  Thanks for the patch.

Note You need to log in before you can comment on or make changes to this bug.