Bug 649140 - modemmanager HSO cid error: hso_get_cid: runtime check failed: (cid >= 0)
modemmanager HSO cid error: hso_get_cid: runtime check failed: (cid >= 0)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-02 21:49 EDT by chrschmitt
Modified: 2013-02-13 15:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 15:13:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chrschmitt 2010-11-02 21:49:15 EDT
Description of problem:

I have problems connecting to the WAN with MM 0.4 while it works with 0.3. I am using a HSO modem.
I get the following error on connect:
(modem-manager:6520): WARNING **: (mm-modem-hso.c:100):hso_get_cid: runtime 
check failed: (cid >= 0)

Version-Release number of selected component (if applicable):
0.4

Steps to Reproduce:
1. Try connecting to a WAN with a HSO modem and MM version 0.4
2.
3.
  
Actual results:
(modem-manager:6520): WARNING **: (mm-modem-hso.c:100):hso_get_cid: runtime 
check failed: (cid >= 0)


Expected results:
Working connection

Additional info:
I bisected the versions between 0.3 and 0.4 and came to the following commit that causes the issue:
59b75b5194c6f2a649ca2a4bd6747f74b220d773
maybe in combination with
e3c87e4e1418a25bb8da9e64eba882d8fa335265
Comment 1 Dan Williams 2013-02-12 17:57:34 EST
Is this still the case with more recent version of MM in F17/F18?

Also, if you see the problem again, please do the following, as root:

mv /usr/sbin/modem-manager /
killall -TERM modem-manager
/modem-manager --debug

and then try to reproduce the problem and attach the log here.  Please attach it as a "Private" attachment since it may contain your IMSI and IMEI.
Comment 2 chrschmitt 2013-02-13 05:24:42 EST
As far as I can tell, no, it works with later versions. Did use MM 2 months ago for the last time and it established the connection. This report is old and I kinda lost track of it. Sorry for that.
Comment 3 Dan Williams 2013-02-13 15:13:38 EST
Not a problem, thanks!

Note You need to log in before you can comment on or make changes to this bug.