Bug 649228 - gen_contents_index takes too long to run after every rpm transaction
Summary: gen_contents_index takes too long to run after every rpm transaction
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ghc
Version: 14
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-03 09:40 UTC by Jens Petersen
Modified: 2010-11-17 23:15 UTC (History)
4 users (show)

Fixed In Version: ghc-6.12.3-7.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-17 23:15:07 UTC
Type: ---


Attachments (Terms of Use)

Description Jens Petersen 2010-11-03 09:40:52 UTC
Description of problem:
gen_contents_index takes upwards of 20s to regenerate
haddock doc indices and is run after every ghc-*-devel
package rpm transaction, which slows down installation,
updates, and removal of haskell libraries significantly.

Version-Release number of selected component (if applicable):
ghc-6.12.3

How reproducible:
every time

Steps to Reproduce:
# cd %{ghcdocbasedir}/libraries
# time ./gen_contents_index
  
Actual results:
On a typical machine with most ghc-*-devel installed
it takes about 25-30s to run.

Expected results:
20-30s wait for script of rpm transaction is unacceptable.

Additional info:
Re-indexing could be moved to a cronjob perhaps (daily or hourly).
Maybe only concern would be to avoid re-indexing while
do ghc-*-devel rpm transactions, but perhaps the chance of
collision is low enough not to worry specially if we run
hourly.  (If there are no changes it can be a no-op
there should not be much system impact even hourly.)

I am going to check if ghc-6.12.1 is affected too.

Comment 1 Jens Petersen 2010-11-04 01:23:53 UTC
I suspect the overriding issue is probably memory pressure,
but a "workaround" seems to be to remove ghc-type-level-devel
(or ghc-type-level-doc on older releases).

I will push an ghc update for F14 that makes gen_contents_index
ignore type-level.  But for F15 I think we should go with
the cronjob.

Comment 2 Fedora Update System 2010-11-04 07:39:44 UTC
ghc-6.12.3-7.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ghc-6.12.3-7.fc14

Comment 3 Jens Petersen 2010-11-04 08:53:51 UTC
Adding initial cronjob implementation to ghc-6.12.3-8.fc15.

Comment 4 Fedora Update System 2010-11-04 23:44:02 UTC
ghc-6.12.3-7.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/ghc-6.12.3-7.fc14

Comment 5 Fedora Update System 2010-11-17 23:15:03 UTC
ghc-6.12.3-7.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.