Bug 64934 - cc1plus coredump while compiling qt-copy from kde cvs [FALSE]
cc1plus coredump while compiling qt-copy from kde cvs [FALSE]
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-14 16:23 EDT by Per Winkvist
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-14 16:23:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Per Winkvist 2002-05-14 16:23:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
I pulled qt-copy (copy of qt with some patches from kde applied) from kde cvs.
While compiling qt-copy/tools/designer/designer I constantly get this seg fault:

g++ -c -pipe -Wall -W -O2 -D_REENTRANT  -DQT_INTERNAL_XML
-DQT_INTERNAL_WORKSPACE -DQT_INTERNAL_ICONVIEW -DDESIGNER -DQT_NO_DEBUG
-DQT_THREAD_SUPPORT -DQT_SHARED -I/usr/include/freetype2 -I../shared
-I../uilib -I../../../src/3rdparty/zlib -I/opt/kde/cvs/qt-copy/include
-I/usr/X11R6/include -I/usr/X11R6/include -I.moc/release-mt/
-I/usr/local/qt/mkspecs/linux-g++ -o splashloader.o splashloader.cpp
g++: Internet fel: Segmentationfault (program cc1plus)




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.export CVSROOT=:pserver:anonymous@anoncvs.kde.org:/home/kde
2.(Enter as pwd)
3.cvs co qt-copy
4. Follow instuctions in README.qt-copy and do "recommended compile line"

Actual Results:  Everything works fine until compiling the splashloader.cpp file.

Expected Results:  Pass of course

Additional info:

*Please note* that I did upgraded my 7.2 installation to 7.3 by downloading
selected packages and upgraded just those (including gcc* binutils, glibc)
Comment 1 Per Winkvist 2002-05-15 16:05:32 EDT
I can compile fine now if I'm in X but still not in console. Probably a memory  
related problem then I assume. I was suprised since I just got this on the 
very same file, all the time, even after reboots :)

Note You need to log in before you can comment on or make changes to this bug.