This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 649553 - system-config-printer doesn't ask for authentication
system-config-printer doesn't ask for authentication
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: polkit (Show other bugs)
14
i686 Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-03 20:07 EDT by Jim Haynes
Modified: 2013-03-05 23:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 13:49:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output from running system-config-printer --debug and rpm -q (2.37 KB, application/octet-stream)
2010-11-04 11:17 EDT, Jim Haynes
no flags Details
output from running system-config-printer --debug and rpm -q (2.37 KB, text/plain)
2010-11-04 11:19 EDT, Jim Haynes
no flags Details
From trying to run system-config-printer 04 Nov 2010 (17.94 KB, text/plain)
2010-11-04 21:57 EDT, Jim Haynes
no flags Details

  None (edit)
Description Jim Haynes 2010-11-03 20:07:23 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.12) Gecko/20101027 Fedora/3.6.12-1.fc14 Firefox/3.6.12

I ran system->administration->printing on a new F14 system, and entered
all the stuff to define my printer, and at the end it never asked me to
authenticate and didn't apply my inputs.  I had to run system-config-printer
as root to get the printer defined and installed.

Reproducible: Always
Comment 1 Jim Haynes 2010-11-03 21:04:02 EDT
By the way I have SELinux disabled
Comment 2 Jim Haynes 2010-11-03 21:09:46 EDT
When I ran it from a terminal window, running as root, I got the following
messages in the terminal window

(system-config-firewall:2300): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

This seems to be broken in Fedora 13 as well now, though it was not broken
when I first installed F13.
Comment 3 Tim Waugh 2010-11-04 10:49:59 EDT
Thanks for reporting this bug.  I need some more information:

Please run 'system-config-printer --debug' from a terminal window, as a non-root user, and attach the output you get to this bug report.

How did you install this system?  It is a clean install or an upgrade from an earlier release?

What does 'rpm -q cups-pk-helper' say?

How are you logged in?  Did you log in from the console through gdm (i.e. selecting a user, then entering your password), or are you logged in remotely in some fashion?
Comment 4 Jim Haynes 2010-11-04 11:17:09 EDT
Created attachment 457823 [details]
output from running system-config-printer --debug and rpm -q

Since my printer is already configured, I started to add another,
nonexistant printer, and then bailed on that.  If this doesn't
give you enough information I will have to delete the existing
printer and repeat trying to add it.
Comment 5 Jim Haynes 2010-11-04 11:19:32 EDT
Created attachment 457824 [details]
output from running system-config-printer --debug and rpm -q
Comment 6 Tim Waugh 2010-11-04 12:27:52 EDT
Well, if you've canceled the operation before getting to the point where it fails, that's not going to get to the point we need to see debug output from. :-)

You can just add another identical print queue but give it a different name.  Please try that.

I'd also like to see:

* What happens when you run this command from a terminal?:

pkcheck --action-id org.opensuse.cupspkhelper.mechanism.devices-get --process $$ --allow-user-interaction

* How was the system installed?

* How are you logged in?

Thanks.
Comment 7 Jim Haynes 2010-11-04 21:57:29 EDT
Created attachment 457986 [details]
From trying to run system-config-printer 04 Nov 2010
Comment 8 Jim Haynes 2010-11-04 23:09:46 EDT
I think what we have here is a more general authentication problem.

I just did a fresh install on another machine and system-config-printer
and other configuration things I tried worked as they should.  Now on
this machine I have not yet disabled SELinux; I left it the way it defaults
to after installation.  On the machine having the problem I have SELinux
disabled, which is the way I normally operate.  In a little while I will
try disabling SELinux on the other machine and see if that breaks
authentication the way it is broken on this machine.
Comment 9 Jim Haynes 2010-11-05 16:24:20 EDT
I think we might as well close this bug report, because the Real Problem
is somewhere else.  I just did a fresh install and let it create a new
home directory for me, and with that it works fine.
system->administration->printing run by me starts up and as soon as I
punch the ADD button it asks for a password as it should.

But when I mount my existing /home so as to use my regular home directory
it fails to ask for a password.  Other things break too, such as
system-config-services when I make a change just sits there forever and
doesn't ask for a password.

So there is something in my home directory that is upsetting the applecart.

BTW I updated the kernel and also the selinux-policy stuff and that did
not affect the results.

And in fact the printer configuration is broken in my F13 system as well,
so something has recently changed in my home directory that breaks
authentication.

Sometimes I think Linux is turning to a monster - no longer do I just
get a "permission denied" error or a message "you must be superuser to
use this program".  Now it seems that authentication involves a long
complicated chain of things that I'm not able to understand.
Comment 10 Tim Waugh 2010-11-08 05:14:59 EST
I'll reassign this to the polkit package, and hopefully the maintainer will have some idea what's going wrong.  It seems bad behaviour that there isn't a more obvious pointer to what the problem is, I agree.
Comment 11 Fedora End Of Life 2012-08-16 13:49:45 EDT
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.