Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 649673

Summary: fv_* cause memory leak in guest on RHEL5@ia64
Product: [Retired] Red Hat Hardware Certification Program Reporter: Caspar Zhang <czhang>
Component: Test Suite (tests)Assignee: Greg Nichols <gnichols>
Status: CLOSED WORKSFORME QA Contact: Red Hat Kernel QE team <kernel-qe>
Severity: medium Docs Contact:
Priority: low    
Version: 1.2CC: qcai, rlandry, sdenham, yuchen
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-27 15:48:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
fv_core guest log
none
result rpm
none
fv_storage guest log none

Description Caspar Zhang 2010-11-04 09:27:06 UTC
Created attachment 457740 [details]
fv_core guest log

Description of problem:

When executing fv_* tests on RHEL5@ia64, memory leak occured in guest.

guest log attached.

Version-Release number of selected component (if applicable):
1.2-R25, RHEL5.6-20101019.0

How reproducible:
100%

Steps to Reproduce:
1. install required packages and run any/all fv_* tests 
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Caspar Zhang 2010-11-04 09:28:07 UTC
Hi Yuwen, please test this bug on RHEL5.5 GA xen kernel to see if it reproduces

Comment 2 chen yuwen 2010-11-05 05:49:30 UTC
Reproduced on RHEL5.5 GA everytime.
Error: could not start the FV Guest.

# virsh start v7ia64
error: failed to get domain 'v7ia64'
error: Domain not found: xenUnifiedDomainLookupByName

The error is different from that of RHEL5.6.
In RHEL5.6, FV Guest can start but run fail as attachment.

Comment 3 chen yuwen 2010-11-05 09:15:15 UTC
Last tests are on system without HVM support.

On system with HVM support, the error of RHEL5.5 GA is the same as RHEL5.6.

Platform: system with key/value HVM=1.
OS: RHEL5-Server-U5_nfs-ia64
V7: 1.2-25

Comment 4 chen yuwen 2010-11-05 09:25:02 UTC
Find in virsh console log that guest use out swap.

Comment 5 Caspar Zhang 2010-11-05 09:26:41 UTC
(In reply to comment #4)
> Find in virsh console log that guest use out swap.

I found that, too. Tested on an ia64 machine with 20G swap but the test ate them up all.

Comment 6 Greg Nichols 2010-11-05 13:20:48 UTC
Please attach /var/v7/results.xml.  Also, what guest and data images are being used?

Comment 7 Caspar Zhang 2010-11-05 15:38:15 UTC
Created attachment 458126 [details]
result rpm

Use this image: ftp://partners.redhat.com/a166eabc5cf5df158922f9b06e5e7b21/hwcert//RHEL5/fv-images/v7ia64.img.tar.bz2

rpm attached. And the console output of guest is in comment 0.

Comment 12 chen yuwen 2011-01-28 04:04:28 UTC
On hp-rx8640-02.rhts.eng.bos.redhat.com:
fv_core, fv_storage FAIL; 
fv_memory, fv_network PASS.

Distro: RHEL5-U6
Kernel: 2.6.18-238.el5xen
V7: v7-1.3-6

Comment 13 chen yuwen 2011-01-28 04:35:18 UTC
Created attachment 475725 [details]
fv_storage guest log

Comment 14 chen yuwen 2011-01-28 05:59:09 UTC
fv_storage fail caused by function doDt() of storage.py in guest.
The command is: "dt enable=aio aios=8 pattern=0xDEADBEEF bs=%s %s" % (bs,options)
fv_storage log: 
...
Total Statistics:
     Output device/file name: /dev/mapper/VolGroup00-LogVol01 (device type=block)
     Type of I/O's performed: sequential (forward)
        Data pattern written: 0xdeadbeef (read verify disabled)
     Total records processed: 16384 @ 32768 bytes/record (32.000 Kbytes)
     Total bytes transferred: 536870912 (524288.000 Kbytes, 512.000 Mbytes)
      Average transfer rates: 3928889 bytes/sec, 3836.806 Kbytes/sec
     Asynchronous I/O's used: 8
     Number I/O's per second: 119.900
      Total passes completed: 1/1
       Total errors detected: 0/1
          Total elapsed time: 02m16.64s
           Total system time: 00m22.08s
             Total user time: 00m03.95s
               Starting time: Thu Jan 27 22:17:14 2011
                 Ending time: Thu Jan 27 22:19:31 2011

returns 0

Total Statistics:
     Output device/file name: /dev/mapper/VolGroup00-LogVol01 (device type=block)
     Type of I/O's performed: sequential (forward)
        Data pattern written: 0xdeadbeef (read verify disabled)
     Total records processed: 11264 @ 65536 bytes/record (64.000 Kbytes)
     Total bytes transferred: 738197504 (720896.000 Kbytes, 704.000 Mbytes)
      Average transfer rates: 7471030 bytes/sec, 7295.927 Kbytes/sec
     Asynchronous I/O's used: 8
     Number I/O's per second: 113.999
      Total passes completed: 1/1
       Total errors detected: 0/1
          Total elapsed time: 01m38.80s
           Total system time: 00m17.35s
             Total user time: 00m05.10s
               Starting time: Thu Jan 27 22:19:31 2011
                 Ending time: Thu Jan 27 22:21:09 2011

returns 65024
Error: dt error !
...

Why did the "records" change from 16384 to 11264? Memory leak?

# dt enable=aio aios=8 pattern=0xDEADBEEF bs=65536 of=/dev/mapper/VolGroup00-LogVol01 records=16384 iotype=sequential dispose=keep disable=verify flags=direct

Total Statistics:
     Output device/file name: /dev/mapper/VolGroup00-LogVol01 (device type=block)
     Type of I/O's performed: sequential (forward)
        Data pattern written: 0xdeadbeef (read verify disabled)
     Total records processed: 16384 @ 65536 bytes/record (64.000 Kbytes)
     Total bytes transferred: 1073741824 (1048576.000 Kbytes, 1024.000 Mbytes)
      Average transfer rates: 14315794 bytes/sec, 13980.268 Kbytes/sec
     Asynchronous I/O's used: 8
     Number I/O's per second: 218.442
      Total passes completed: 1/1
       Total errors detected: 0/1
          Total elapsed time: 01m15.00s
           Total system time: 00m00.02s
             Total user time: 00m00.32s
               Starting time: Thu Jan 27 23:56:28 2011
                 Ending time: Thu Jan 27 23:57:43 2011
# echo $?
0

Comment 15 Greg Nichols 2011-04-27 15:48:20 UTC
I suspect the swap partition in your image is not set up correctly.