Bug 64968 - cpio doesn't work with large files
cpio doesn't work with large files
Status: CLOSED DUPLICATE of bug 105617
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: cpio (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-15 04:45 EDT by David Stevenson
Modified: 2007-11-30 17:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Stevenson 2002-05-15 04:45:51 EDT
Description of Problem: ls <3GB-file> | cpio -oaBcv > <tape> fails with


Version-Release number of selected component (if applicable): cpio-2.4.2-23


How Reproducible: every time


Steps to Reproduce:
1. ls <3GB-file> | cpio -oaBcv > <tape>
2. 
3. 

Actual Results:
cpio: oes01.dbf: Value too large for defined data type

Expected Results:
Successful copy to tape


Additional Information:
workaround:  use tar or dump
Comment 1 Bernhard Rosenkraenzer 2002-05-21 10:44:09 EDT
cpio has been built with large file support in 7.3.
Comment 2 Bastien Nocera 2003-02-13 05:12:58 EST
Bug is reproduceable with Red Hat Linux 7.3 with cpio-2.4.2.-26 and under Phoebe
2, with cpio-2.5.-1.
Comment 4 Neal Hamlin 2003-05-14 06:09:07 EDT
Please can you tell me when this problem will be resolved as we have around 25 
unix platforms using cpio and have restore scripts built around this program.
Comment 5 Bastien Nocera 2003-05-15 05:54:24 EDT
This bug has already been fixed on Red Hat Linux 8.0 and 9, you can recompile
the source RPMs from these versions onto the release you are using.
Comment 6 Stuat J. Browne 2003-07-10 20:26:20 EDT
I grabbed both the 2.4.2-28 and 2.5-3 source RPM for cpio and re-compiled it on 
a RH7.3 box using:

rpmbuild --rebuild cpio-<ver>.src.rpm
rpm -Uvh /usr/src/redhat/RPMS/i386/cpio-<ver>.i386.rpm

and both versions returned the same error:

/bin/cpio: ./bigfile: Value too large for defined data type

Next thing to look at?
File was just over 3GB in size, using:

find . -mount -print0 | /bin/cpio -0 -H newc -o -C 10240 -O /dev/nst0
Comment 7 paulm 2004-04-02 13:16:13 EST
I got same error on fedora core 1 (with a 4G file)
This is an old bug- any hope for some attention?
Comment 8 Peter Vrabec 2004-11-01 09:16:23 EST

*** This bug has been marked as a duplicate of 105617 ***
Comment 9 Red Hat Bugzilla 2006-02-21 13:48:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.