This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 6497 - /etc/X11/applnk/*/*.desktop files not seen by gmenu
/etc/X11/applnk/*/*.desktop files not seen by gmenu
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
6.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-29 09:34 EDT by Telsa Gwynne
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 15:23:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
test (162.30 KB, application/octet-stream)
1999-11-03 13:06 EST, David Lawrence
no flags Details

  None (edit)
Description Telsa Gwynne 1999-10-29 09:34:00 EDT
I'm told this might be a packaging error rather than a Gnome
one. Running RH 6.1 with October Gnome, I see two Gimps and XDvi
in the Graphics menu and only one (and no XDvi) in the menu
editor. Many other items are missing from the menu editor too.
I just found all the .desktop files for the 'missing' ones in
/etc/X11/applink/*. They're getting picked up by whatever
controls the Gnome menus, but not by the menu editor.
Comment 1 David Lawrence 1999-11-23 10:34:59 EST
I have verified this to be a problem. I am assigning this to a developer for
further review.
Comment 2 Owen Taylor 1999-12-01 10:24:59 EST
It's pretty hard to do anything about this, since you'd have
to (somehow) in the GUI let the user specify whether each item
should live in /etc/X11/applink or in /usr/share/gnome/apps.

My best idea for a fix would be adding the ability to switch
gmenu from editing one set of menus to adding another.

This is probably not worth fixing until the menu merging code
becomes a standard part of GNOME (which may wait until /etc/X11/applnk
or an alternative is standardized across distributions); the
operation of gmenu for a user is unaffected.
gmenu p
Comment 3 Owen Taylor 1999-12-01 10:26:59 EST
Since my last comment looks unclear to me, what I meant was
that unless you are running gmenu as root (to edit the menus
for all users), then this problem won't matter, since normal users
can only edit the "User Menus" section.

Note You need to log in before you can comment on or make changes to this bug.