Bug 64971 - Installer hangs when loading aic7xxx module on Intel L440GX+ motherboard and Astor II chassis
Installer hangs when loading aic7xxx module on Intel L440GX+ motherboard and ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-15 05:32 EDT by Brian
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-21 05:10:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from dmidecode (7.49 KB, text/plain)
2002-05-21 05:10 EDT, Brian
no flags Details

  None (edit)
Description Brian 2002-05-15 05:32:58 EDT
From Bugzilla Helper:

User-Agent: Mozilla/4.0 (compatible; MSIE 5.14; Mac_PowerPC)



Description of problem:

Installer seems to hang during the initial 'loading aic7xxx' module 
message.



Version-Release number of selected component (if applicable):





How reproducible:

Always



Steps to Reproduce:

1. Insert bootable installation cd-rom

2. Turn on PC



Actual Results:  The installer hangs.



Expected Results:  The installer completes



Additional info:



This identical problem happened under the 7.2 install, and it was 
determined that there was a bug between the 2.4.x kernel running in non-
SMP mode and the aic7xxx card that is embedded into the motherboard. 
The solution was that a redhat person uploaded some install images 
which were SMP enabled.



(As I recall, it was a problem with the APIC system?)
Comment 1 Brian 2002-05-16 17:36:15 EDT
I guess I should have looked a bit harder, because I was able to get this 
working using workarounds from previous redhat versions. It would be nice if 
this issue could be resolved sometime, as it seems to have reappeared in every 
redhat since 7.1. I don't recall other distributions having the same symptoms 
during that time period.

(the 'linux apic' commandline option fixed this one)
Comment 2 Arjan van de Ven 2002-05-20 08:06:48 EDT
It's an Intel bios bug; please contact intel for an upgrade
Comment 3 Arjan van de Ven 2002-05-21 04:26:35 EDT
Also please run the dmidecode program from the kernel-utils
package and attach the output; with that we can make the "apic"
automatic for your exact bios
Comment 4 Brian 2002-05-21 05:10:17 EDT
Created attachment 58088 [details]
Output from dmidecode
Comment 5 Benjamin Scott 2003-05-06 22:07:38 EDT
We have an L440GX+ board that exhibits this problem.  The various "pci=", SMP
kernel, and "apic" workarounds did not help.  Fortunately, the system we were
installing to had a RAID controller (used a different driver), and an IDE
CD-ROM.  So, we did a "noprobe" install, skipped the "aic7xxx" driver, and got a
working system.

We then downloaded kernel 2.4.20 (final release, pristine sources), did a custom
build, and tried that.  It worked perfectly.  It appears that Alan Cox obtained
information from Intel that lead to a fix.

See also Bug 78234 (against RHL 8.0), which lead me to this solution.

Note You need to log in before you can comment on or make changes to this bug.