Bug 64979 - Unable to handle wireless LAN devices (ARPHRD_IEEE80211) correctly
Summary: Unable to handle wireless LAN devices (ARPHRD_IEEE80211) correctly
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pump   
(Show other bugs)
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-15 15:52 UTC by Need Real Name
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 20:44:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
making pump work in a correct way with 802.11 devices (729 bytes, patch)
2002-05-15 17:28 UTC, Need Real Name
no flags Details | Diff

Description Need Real Name 2002-05-15 15:52:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020502

Description of problem:
IEEE80211 devices set the hardware type to 80211, but the DHCP/BOOTP request
needs to have the hardware type set to 0x01 (ethernet)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.plug in a wireless LAN card - with 80211 support in the driver,
and execute pump :)


Actual Results:  nothing :)
the host just sends request, but doesn't get anything back (due to the wrong
hardware type field)

Expected Results:  pump should work as usuall

Additional info:

the code for the actual driver is not in the kernel right now, so this makes it
not realy ugent - but a nice to have.

btw. i have a simple patch, but cannot find a place in this form where to put it ;)

Comment 1 Need Real Name 2002-05-15 17:28:34 UTC
Created attachment 57444 [details]
making pump work in a correct way with 802.11 devices

Comment 2 Eido Inoue 2004-08-23 20:44:21 UTC
in cvs, not in pkgs. wireless device support in current releases
supported by dhclient


Note You need to log in before you can comment on or make changes to this bug.