Bug 649821 - Firefox Mozilla Firefox 3.6.12 crashing on Fedora 14 x86_64
Summary: Firefox Mozilla Firefox 3.6.12 crashing on Fedora 14 x86_64
Keywords:
Status: CLOSED DUPLICATE of bug 639985
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 14
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-04 16:02 UTC by Harish Pillay
Modified: 2011-01-06 17:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-06 17:26:41 UTC
Type: ---


Attachments (Terms of Use)

Description Harish Pillay 2010-11-04 16:02:00 UTC
Description of problem:
Firefox is not starting on F14 64 bit.  It crashes.

Version-Release number of selected component (if applicable):

Firefox 3.6.12
Fedora 14 x86_14

How reproducible:
either click on the Firefox icon or start firefox from the terminal.

Steps to Reproduce:
1. click on Firefox icon - crash.
2. or start firefox from the console.
3.
  
Actual results:
[harish@vostro ~]$ firefox 
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site.py", line 553, in <module>
    main()
  File "/usr/lib64/python2.7/site.py", line 536, in main
    known_paths = addsitepackages(known_paths)
  File "/usr/lib64/python2.7/site.py", line 315, in addsitepackages
    addsitedir(sitedir, known_paths)
  File "/usr/lib64/python2.7/site.py", line 188, in addsitedir
    addpackage(sitedir, name, known_paths)
  File "/usr/lib64/python2.7/site.py", line 158, in addpackage
    exec line
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/abrt_exception_handler.py", line 28, in <module>
    import subprocess
  File "/usr/lib64/python2.7/subprocess.py", line 428, in <module>
    import select
ImportError: /usr/lib64/python2.7/lib-dynload/selectmodule.so: undefined symbol: _Py_ZeroStruct
[harish@vostro ~]$ 

Expected results:
Firefox should startup correctly.

Additional info:
This is a machine that did a preupgrade from Fedora 13 x86_64 to Fedora 14 x86_64.

Comment 1 drobles 2010-11-05 18:21:23 UTC
Same here, uninstalling xulrunner-python solved the problem for me.
Weird thing is that after installing the packet again, firefox worked fine.
May be something wrong with the preupgrade steps.

Comment 2 drobles 2010-11-05 18:23:38 UTC
Same bug as in 639985.

Comment 3 Martin Stransky 2011-01-06 17:26:41 UTC

*** This bug has been marked as a duplicate of bug 639985 ***


Note You need to log in before you can comment on or make changes to this bug.