Bug 64988 - zebra/ripd does't update kernel routeing table
Summary: zebra/ripd does't update kernel routeing table
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: zebra   
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
high
high
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-15 18:20 UTC by Gary A. Ernst
Modified: 2014-08-31 23:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-30 15:42:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gary A. Ernst 2002-05-15 18:20:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4.1) Gecko/20020314
Netscape6/6.2.2

Description of problem:
Zebra does not update kernel routing table from learned rip v2 updates. show ip
route and show ip rip report the expected routes but route -n does not reflect
learned routes. Additionally, When a tunnel is added via hercules zebra deletes
the default route. zebra and ripd are the only routeing protocl daemons running.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start zebra on a network that is known to send multicast ripv2 routes
2.Start ripd on same
3.
	

Actual Results:  No routes are added

Expected Results:  route command should show same routes as show ip route issued
from zebra vty.

Additional info:

Note The same level of zebra/ripd work fine on a slackware based box at the same
kernel level 2.4.18 and zebra-0.92a

Comment 1 Elliot Lee 2002-05-15 18:23:49 UTC
Your best bet for a quick solution is probably to ask upstream - the zebra
mailing list etc.

Comment 2 Gary A. Ernst 2002-05-15 21:27:54 UTC
Have you verified functionality at the given levels ?

Comment 3 Elliot Lee 2002-05-15 21:33:00 UTC
nope.

Comment 4 Gary A. Ernst 2002-05-15 22:41:36 UTC
Then what am I supposed to go to the zebra site with ? It works on slackware not
on RedHat ? What suggestions do you suppose I'll get ?

Comment 5 Elliot Lee 2002-05-15 22:50:15 UTC
The zebra site will put you in touch with people who know zebra from the ground
up, and others who may be experiencing the same problem. I can do neither.


Comment 6 Jos Vos 2002-08-14 14:28:15 UTC
I have a similar problem on RH 8.0 beta.  It appears that Zebra 0.92a has a
problem.  Versions 0.91a and 0.93a do not have this problem.  It relates to the
fact that it considers the RIP routes coming from a non-active link, *because*
that link is a kernel route.  We have remade the RH rpm with 0.93a and now it
works!

Comment 7 Ted Kaczmarek 2003-01-25 17:21:28 UTC
I have seen this issue with many recent versions myself. Been perplexing trying to
identify root cause, but restarting network and bgpd resolves it every time. Not
a very good work around for a routing daemon.

Comment 8 Ted Kaczmarek 2003-01-25 17:22:38 UTC
Forgot to mention with bgp routes :-) And yes I do see them in the bgp table.

Comment 9 Jay Fenlason 2004-06-30 15:42:37 UTC
Red Hat Linux 7.3 is no longer supported.  If you can reproduce this
problem with a currently supported product, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.