This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 64990 - Installer fails when loading AIC7xxx module
Installer fails when loading AIC7xxx module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-15 14:40 EDT by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-15 14:40:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I can't install Redhat 7.2 (or RH6.2 2.2.14-6.1.1) onto a Dell PowerEdge 6300. 
I was previously able to install 6.2 onto this machine fine. I have recently 
installed a Dell PERC3/QC RAID card. To make sure I had done it correctly I 
test installed NT 4.0 Server and that worked fine.
Problem is this: When selecting the Adaptec SCSI driver (AIC-7xxx) there is a 
brief message saying it is loading, but the screen instantly goes black 
(powersave mode) and the machine is totally locked up.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot Installer CD
2. Choose expert mode
3. Choose Apaptec driver for AIC7xxx
	

Actual Results:  Machine locked up, screen goes black, have to power off.

Expected Results:  Installer should have loaded driver and continued.

Additional info:

I have talked through with Dell, and checked I have done everything correctly.  
Test installed NT 4.0 Server and that works fine.
Comment 1 Michael Fulbright 2002-05-20 15:22:50 EDT
This appears to be a kernel related issue.
Comment 2 Arjan van de Ven 2002-05-20 15:28:04 EDT
can you try typing "linux apic" on the very very first screen with the prompt ?
Comment 3 Need Real Name 2002-05-23 03:44:26 EDT
I have tried typing "linux apic" on the very first screen that I get access to 
when booting from Install Disk 1 - the "boot:" prompt.  There is no screen 
before this with a "?" prompt as it very quickly loads the boot: prompt after 
initializing the RAID card.  This has NO effect at all, same result as before.
Further information:
Dell had escalated this internally, but now say they have no answer and refer 
me back to RedHat.
1) I have now also tried RH 7.0, and still the same problem.  SO it doesn't 
work with 6.2, 7.0, or 7.2
2) I checked the PowerEdge 6300 is certified by RedHat for RH 6.2, 7.0, 7.2
3) The PERC 3/QC uses the megaraid driver.  I am using Dell's latest for 6.2 
and 7.0.  This driver appears to load fine for 7.0 (disk) and 7.2 (RH CD).
4) The PowerEdge 6300 accepts a RedHat install fine without the PERC 3/QC card.
5) Windows NT Server 4.0 installs fine with or without the PERC 3/QC card.
6) The server has the latest BIOS and Firmware upgrades from Dell.  A12 for 
System BIOS.  A04 (161N) for PERC 3/QC RAID card.  A42 for ESM Firmware.  
Server diagnostics report no errors.
7) The PERC 3/QC is in PCI slot 7 (Highest) and BIOS set to scan from High to 
Low at boot time.
8) This server has two CPUs.
9) I have now disabled the motherboard Primary SCSI A and B from the System 
BIOS.  This causes the Dual Adaptec AIC7860 controllers to be masked off (they 
are not needed as all my HDDs are now attached via the System Backplane to the 
PERC RAID card.  This leaves only the motherboard Secondary SCSI controller 
single Adaptec AIC7890 enabled for the CDROM (to let me install RH).
10) The only other PCI device is an Intel NIC which is extra to the two 
motherboard Intel NICs.
11) I have tried these other boot: prompt options in various combinations, with 
no change in result: linux expert dd apic noprobe text
12) I have tried using Alt+F4 after entering apic boot option but computer 
locks up with no output displayed.
13) The server has hardlocked, that is even CapsLock key does nothing.  Only 
way is to power off at this point.
14) Searching the Bugzilla list for AIC7xxx shows more than 50 bugs.  Reading 
through these has left me feeling helpless (see Bug #'s 64971, 64686, 64319, 
58026, 55942, 55588, 54949, 54422, 53644, 52195, 51859, 51370, 44109, 41813, 
19328).
*** Please *** do you have any further suggestions how I can get this server up 
and running quickly with RH, or I'll have to switch back to Microsoft :-(
Comment 4 Bugzilla owner 2004-09-30 11:39:35 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.