Bug 64999 - Crashes in glibc with locale no_NO
Crashes in glibc with locale no_NO
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-15 15:34 EDT by Kjartan Maraas
Modified: 2016-11-24 10:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-15 08:05:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2002-05-15 15:34:34 EDT
Description of Problem:

I'm trying to hunt down a crash in the gnome panel and I've found a different
one in gnome-libs' test program. This only occurs when I run with the no_NO
locale and goes away if I remove the norwegian translation for libc.

I've been using efence to trigger this btw.
Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. run test-gnome from gnome-libs in gdb
2. set env LD_PRELOAD=/usr/lib/libefence.so
3. set env EF_PROTECT_FREE=1
4. run, and select the icon-entry button, then click the empty icon entry.

Actual Results:

Crash.
Expected Results:


Additional Information:
	
Backtrace:

[Switching to Thread 1024 (LWP 1860)]
0x404a5d79 in _nl_find_msg (domain_file=0x43a0bfe8, domainbinding=0x0, 
    msgid=0x405aa665 "Success", lengthp=0xbfffe668) at dcigettext.c:782
782
dcigettext.c: No such file or directory.
	in dcigettext.c
(gdb) bt
#0  0x404a5d79 in _nl_find_msg (domain_file=0x43a0bfe8, domainbinding=0x0, 
    msgid=0x405aa665 "Success", lengthp=0xbfffe668) at dcigettext.c:782
#1  0x404a5443 in __dcigettext (domainname=0x405a4dbc "libc", 
    msgid1=0x405aa665 "Success", msgid2=0x0, plural=0, n=0, category=5)
    at dcigettext.c:587
#2  0x404a4d9d in __dcgettext (domainname=0x405a4dbc "libc", 
    msgid=0x405aa665 "Success", category=5) at dcgettext.c:53
#3  0x40503368 in __strerror_r (errnum=0, buf=0x405b47e0 "", buflen=1024)
    at ../sysdeps/generic/_strerror.c:68
#4  0x4050330b in strerror (errnum=0) at strerror.c:30
#5  0x401a95b8 in dlerror () at dlerror.c:71
#6  0x40458d16 in fetch_dlerror () at gmodule-dl.c:80
#7  0x40458e89 in _g_module_symbol (handle=0x4a29ddd0, 
    symbol_name=0x404599bc "g_module_check_init") at gmodule-dl.c:140
#8  0x404597e7 in g_module_symbol (module=0x4a2a5fec, 
    symbol_name=0x404599bc "g_module_check_init", symbol=0xbfffe7d8)
    at gmodule.c:381
#9  0x404593ef in g_module_open (
    file_name=0x4a299fe4 "/usr/lib/libimlib-png.so", flags=G_MODULE_BIND_LAZY)
    at gmodule.c:264
#10 0x40305b10 in get_module_loader_saver (mod=0x4030763d "png", 
    loader=0x40308c3c, def_loader=0x40305ab4, saver=0x40308c48, 
    def_saver=0x40305abc) at modules.c:90
---Type <return> to continue, or q <return> to quit---
#11 0x40305cf8 in load_module_relay (mod=0x4030763d "png", lf=0x40308c3c, 
    sf=0x40308c48, f=0x4a295e94, w=0xbfffe8b0, h=0xbfffe8b4, t=0xbfffe8b8)
    at modules.c:151
#12 0x40305ed2 in loader_png (f=0x4a295e94, w=0xbfffe8b0, h=0xbfffe8b4, 
    t=0xbfffe8b8) at modules.c:210
#13 0x402ee4d5 in gdk_imlib_load_image (
    file=0x49755fdc "/usr/share/pixmaps/abiword_48.png") at load.c:283
#14 0x4009fae4 in append_an_icon (gis=0x488cafac, 
    path=0x49755fdc "/usr/share/pixmaps/abiword_48.png")
    at gnome-icon-sel.c:220
#15 0x400a011b in gnome_icon_selection_show_icons (gis=0x488cafac)
    at gnome-icon-sel.c:399
#16 0x400a20d4 in show_icon_selection (b=0x469baee8, ientry=0x47accfac)
   at gnome-icon-entry.c:446
#17 0x4039780b in gtk_marshal_NONE__NONE (object=0x469baee8, 
    func=0x400a1bac <show_icon_selection>, func_data=0x47accfac, 
    args=0xbfffea60) at gtkmarshal.c:312
#18 0x403c6e76 in gtk_handlers_run (handlers=0x409f9060, signal=0xbfffea00, 
    object=0x469baee8, params=0xbfffea60, after=0) at gtksignal.c:1917
#19 0x403c62d7 in gtk_signal_real_emit (object=0x469baee8, signal_id=88, 
    params=0xbfffea60) at gtksignal.c:1477
#20 0x403c434c in gtk_signal_emit (object=0x469baee8, signal_id=88)
    at gtksignal.c:552
---Type <return> to continue, or q <return> to quit---
#21 0x40336ee0 in gtk_button_clicked (button=0x469baee8) at gtkbutton.c:336
#22 0x40338456 in gtk_real_button_released (button=0x469baee8)
    at gtkbutton.c:861
#23 0x4039780b in gtk_marshal_NONE__NONE (object=0x469baee8, 
    func=0x403383b0 <gtk_real_button_released>, func_data=0x0, args=0xbfffedf0)
    at gtkmarshal.c:312
#24 0x403c6183 in gtk_signal_real_emit (object=0x469baee8, signal_id=87, 
    params=0xbfffedf0) at gtksignal.c:1440
#25 0x403c434c in gtk_signal_emit (object=0x469baee8, signal_id=87)
    at gtksignal.c:552
#26 0x40336e24 in gtk_button_released (button=0x469baee8) at gtkbutton.c:327
#27 0x40337dcb in gtk_button_button_release (widget=0x469baee8, 
    event=0x4727c018) at gtkbutton.c:721
#28 0x403975e1 in gtk_marshal_BOOL__POINTER (object=0x469baee8, 
    func=0x40337d08 <gtk_button_button_release>, func_data=0x0, 
    args=0xbffff190) at gtkmarshal.c:28
#29 0x403c6317 in gtk_signal_real_emit (object=0x469baee8, signal_id=27, 
    params=0xbffff190) at gtksignal.c:1492
#30 0x403c434c in gtk_signal_emit (object=0x469baee8, signal_id=27)
    at gtksignal.c:552
#31 0x403fa3a8 in gtk_widget_event (widget=0x469baee8, event=0x4727c018)
    at gtkwidget.c:2864
#32 0x40397558 in gtk_propagate_event (widget=0x469baee8, event=0x4727c018)
---Type <return> to continue, or q <return> to quit---
    at gtkmain.c:1378
#33 0x40396715 in gtk_main_do_event (event=0x4727c018) at gtkmain.c:818
#34 0x4043dd5b in gdk_event_dispatch (source_data=0x0, 
    current_time=0xbffff560, user_data=0x0) at gdkevents.c:2143
#35 0x4046ae41 in g_main_dispatch (dispatch_time=0xbffff560) at gmain.c:656
#36 0x4046b445 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#37 0x4046b5d4 in g_main_run (loop=0x47274ffc) at gmain.c:935
#38 0x40396013 in gtk_main () at gtkmain.c:524
#39 0x08055ac4 in main (argc=1, argv=0xbffff734) at testgnome.c:1961
#40 0x40498647 in __libc_start_main (main=0x80557b4 <main>, argc=1, 
    ubp_av=0xbffff734, init=0x804bbdc <_init>, fini=0x8055b20 <_fini>, 
    rtld_fini=0x4000dcd4 <_dl_fini>, stack_end=0xbffff72c)
    at ../sysdeps/generic/libc-start.c:129
(gdb) 


I've tried the glibc errata for 7.2 and current rawhide glibc.
Comment 1 Kjartan Maraas 2002-06-04 09:23:06 EDT
Any news on this? Is this crashing because efence is doing wrong things or is it
a legitimate crash?
Comment 2 Kjartan Maraas 2002-08-24 17:41:59 EDT
Close this?
Comment 3 Kjartan Maraas 2003-01-15 08:05:50 EST
Closing. I think this was a problem somewhere else in the code.

Note You need to log in before you can comment on or make changes to this bug.